Honda D Series Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi there. I’ve been working on building my turbo z6 and got everything done. Had some trouble keeping it running until after I did the valve lash adjustment. It now starts and runs(with a surging idle, my tuner should be able to tune that out hopefully) but had a terrible knocking sound. Originally thought I spun a bearing so I dropped the downpipe and oil pan. Checked the rods and everything seems tight. Turned the crank by hand and had trouble pinpointing the sound but found out that when the clutch is pressed in and turned the crank over by hand the sound goes away. Put everything back together fired her back up and found that when clutch pressed in it sounds good but once the clutch is let out it knocks something fierce. Hoping somebody has an idea of what this may be. Thanks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
I was doing some reading and that what seems to be most peoples issue. Shouldn’t be the tob though that, clutch and flywheel are all new. Wasn’t greased though....
 

·
Registered
08 H-D Ultra Classic
Joined
·
986 Posts
ISB or input shaft bearing would be my first guess
 

·
Registered
Joined
·
4 Posts
I had a similar problem when my transmission "lost" a couple bolts and wasn't sitting straight (shady mechanic didn't tighten anything down after swapping the engine). I would check the bearing make sure the tranny bolted up tight.
 
1 - 8 of 8 Posts
Top