Honda D Series Forum banner

1 - 15 of 15 Posts

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #1
okay guys got 88 hatch with b7bottom end and y8 head. i just picked up a y8 im. the car was running perfect before im. now the car will only start with starter fluid then die. i got fuel pressure 42 psi and brand new fpr. i am using the y8 fuel rail that came with im but the old b7 injectors i was already using. any ideas on what to check now? i assume the injectors arent firing.
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #4 (Edited)
ya i got 12 volts to all four. no cel is being thrown either. however i did notice that one of the injectors on the nozzle side that little cone piece that goes around it was missing on one of them.
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #6
yup got fuel also pulled the entire fuel rail with injectors still connected and it is spraying plenty of fuel
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #8
ya before mani swap had b7 mani with obd1 dizzy and p28 ecu only thing i changed was the manifold itself. prior to changing manifolds had no issues. could i some how have a vacuum leak?>
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #10
well i said they are firing now i am getting fuel and spark but still not starting except with starter fluid
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #12 (Edited)
okay if i pulled the return fuel line off no fuel is coming out of the fpr where it connects to return line?? but injectors our spraying fuel. confused??
 

·
Registered
88 Hatch
Joined
·
19 Posts
Discussion Starter #14
Man i figured it out thanks so much to you. it ended up being fuel rail clogged with dirt. apparently the guy i bought it from didn't take care of it. took off the rail cleaned it all reinstalled and car fired up. thanks for your help.
 
1 - 15 of 15 Posts
Top