Honda D Series Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
hey guys so im about to pick up a z6 head for my 98 civic hatch with a y7 in it and my cars obd2 and the heads obd1 is there anything ill have to change up like wat gasket i should use and wat i all need to complete this transaction cuz i need to finish this within a day cuz i need my car to get to work and all please help ur info is greatly appriciated!!!!!
 

·
Registered
Joined
·
11 Posts
use the z6 head gasket because its a z6 head....i believe you should use either the y8 cam/sprocket because they cam/sprockts diff... i believe i have seen ppl use the z6 cam with the y8/y7 sprocket.....correct me if im wrong...use your y7 sensors because they are all obd1.....what IM are you useing?
 

·
Registered
1994 EH9
Joined
·
616 Posts
i just did the same exact swap. I used a z6 head gasket,oem z6 camgear,the y7 timing belt. Runs beautiful,couldnt be happier with the way it is now
 

·
Registered
A space ship
Joined
·
628 Posts
Fist off, start on Friday after work. Now you have 2 1/2 days to finish. The z6 cam gear will work just fine. You will need the z6 timing belt, plug wires, and plugs (id go a few heat ranges colder than the z6 plugs). And don't forget that oil jet
[/IMG]
You will also need to get your ecu converted and chipped, but you can drive on your stock ecu for a while if you must. If your using the z6 im you will need all the sensors and new coolant lines, fuel line/rail, im support bracket. Any other questions? I will also refer you to the stickies in the engine building section, lots of good info there.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6 (Edited)
hey thanks alot guy but i still dont noe exactly sure cuz some says one thing some says another lol but yea it a complete z6 head wit mani and all...
 

·
Registered
Joined
·
1,211 Posts
use the z6 head gasket because its a z6 head....i believe you should use either the y8 cam/sprocket because they cam/sprockts diff... i believe i have seen ppl use the z6 cam with the y8/y7 sprocket.....correct me if im wrong...use your y7 sensors because they are all obd1.....what IM are you useing?
:noway:
 

·
Registered
Joined
·
11 Posts
Quote:
Originally Posted by hondatuning1994 View Post
use the z6 head gasket because its a z6 head....i believe you should use either the y8 cam/sprocket because they cam/sprockts diff... i believe i have seen ppl use the z6 cam with the y8/y7 sprocket.....correct me if im wrong...use your y7 sensors because they are all obd1.....what IM are you useing?
haha i totally went by what i heard on that one so dont Quote me lol

and that y7 obd1 haha idk were tha hell that came from early mornin
 

·
Registered
Joined
·
1,211 Posts
haha i totally went by what i heard on that one so dont Quote me lol

and that y7 obd1 haha idk were tha hell that came from early mornin

uuhhh... so i guess u like to wake and bake???:bong:
 

·
Registered
Joined
·
3 Posts
i have a y7 timing belt on mine rightnow and it wont start its kinda turnin. sounds like timings offff.. how do you set the timing on y7block z6head z6camgear... do i need to use the z6 timing belt? or get different gear
 

·
Registered
A space ship
Joined
·
628 Posts
Use the timing marks. Set the head to tdc and the block to tdc, install belt. I think on a y7/z6 your still going to have some slight timing issues(i could be wrong) so go a notch advanced or retarded, your choice.
 

·
Registered
Joined
·
3 Posts
thanks! everytime i get them both to tdc.. go to slide belt on the bottom pulley moves towards firewall. ive been sliding the belt on from side too... i might be messin up.. but two others tried and the same thing happend
 

·
Registered
Joined
·
4,732 Posts
must be doing somthing wrong. i have y7 /z6 head. vitaras an shit....runs perfect Y7 timing belt, Z6 head gasket. Z6 cam gear. and i set the timing with no marks..i used a straw.
 
1 - 16 of 16 Posts
Top