Honda D Series Forum banner

21 - 36 of 36 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #22
Any, ideas what I should do with the two wires that are currently no plugged in.

1. Should I remove the wires that are in their spots, and plug the new (added) ones in?
2. Leave Them unplugged and see if I get a 'check engine light'?
3. Trace the wires back to see where they go... ugh this would be lots of work.
4. any other suggestions?

--- You all are a great help, Thanks for everything ---
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,946 Posts
ask em at Honda while youre there. they have fancier manuals and schematics
 

·
Premium Member
Joined
·
5,819 Posts
2,3,1 in that order.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #25
Took the car to Honda today to get the immobilizer flashed. After quite a while they came back and told me I had the wrong computer. I bought a 'Jdm Honda Civic 01-05 D17a Sohc Automatic Vtec Ecu 37820-psa-j52'. I guess the JDM version doesn't work here.

Anyways, I can get my hand on a Honda Civic 01-05 Automatic EX version ($75). Do you think that would work?

ask em at Honda while you're there. they have fancier manuals and schematics
Honda said they can't give advice on the wires, and didn't have a book for me to go through while I waited... real nice.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,946 Posts
oh, they have a computer system. but they wont allow you to do it. will the flash work with another ecu or are you going to have to go back and do it again?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #27
@slo_eg8 I am going to go get another computer today (If work allows) and then take the new computer to honda tomorrow.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #30
Update: I got a new computer, I went back to Honda and they were able to flash the immobilizer and sync with my key.

Now... I can't rev above 4000 RPM. Everything works fine when up to 4k then it stops accelerating and makes a sound as if it's bouncing off the rev limiter.

This makes me think there are three problems,
1. The wires are in the wrong spot.
2. The new computer from the wreckers is wrong.
3. The VTEC Solenoid is bad (unlikely)

Any other ideas?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,946 Posts
limp mode. find out the code its throwing.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #32
It's not throwing a code. At least there isn't a check engine light or any other light on the dash that shouldn't be there.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #33
Update... Nothing new to report.

I have been driving around in limp mode for a few weeks now, everything works fine except I can't get above 4k RPM. There are no lights on the dash that shouldn't be on. It does smell like it's burning up my cat as a get a HOT metal smell as it drives, but the temp is fine.

I think I am going to rebuild my old engine and put it back into the car and forget about going to VTEC.

All those people (salesmen) that told me it was only 2 additional wires were wrong. There are at least 8 wires and possibly reorganize your wiring loom. Not to mention needing an entirely new exhaust system where you have to wire up a new O2 sensor and add that to another section of the wiring harness along with and new ECU that you have to get flashed at the dealership.

^^^ I hope my post helps people in the future.
 

·
\/Your Mom Was Here\/
Joined
·
4,831 Posts
The d17a2 does use a different exhaust and 02 sensor. 04-05 uses a wideband sensor up top even though your car isn't that new you would have to look at the ECU to know what year it came out of (it might be looking for the wideband sensor). Then you still need to wire the vtec solenoid.
 

·
Registered
Joined
·
2 Posts
I found this information ... if the problem is the o2 sensor this post can help
I'm not sure if I can post from other forums but jimmyjet has put a lot of effort and I'm pretty sure this can help.



I just did this my 2005 Civic LX (non VTEC) blew up and replaced it with a 2003 Civic EX VTEC Motor, Trans, wire harness and ECU

Some of the wires are a little different between the 2
There are differences between the Motor harness and the body harness.

All good after flash from Honda
Keys work now with the ECU that matches the motor need to do this if you change the ECU. The motor ran on the LX computer just thew codes for the O2 sensors.
Only code its throwing was the heater on O2 sensor 2 which if you get the harness from the motor there is no place to connect the Downstream O2 sensor as the exhaust is different between the 2 motors. I changed my exhaust also, used a aftermarket LX header back exhaust and just added the 2nd O2 sensor about mid car and left the plug in the header for O2 number 2. You will also need the O2 sensors for the EX motor as they are different between LX and EX
Wired the Black/Yellow wire to pin 5 yel/blu on connector E
Wired all O2 stuff to connector E and all good now, No codes

So just so its cleared up for anyone else doing a LX - EX conversion in a 2001-2005 Civic here is where the wires are landed when using EX Motor, Trans, Wire Harness and ECU

Here is where they are on the stock harness Connector A (31 pins)
25 wht/red Secondary O2
23 brn/yel Logic Ground
14 blk/wht SecondaryO2 sensor heater control
10 grn/yel Sensor ground
Blk/yel Heater acc power

Here is where they go on Connector E (31 pins)

2 wht/red Secondary O2
3 brn/yel Logic Ground (Shield from O2 Sensor)
5 yel/blu Sensor voltage (attach to blk/yel from O2 Sensor)
6 blk/wht SecondaryO2 sensor heater control
Connector A (31 pin)
10 grn/yel Sensor ground

On the wht/red and Blk/wht
I dissected the old harness to get the whole wire with the metal ends that fit into the harness. As you will find out when going from LX to EX there are a few different wires and they are not in both body harnesses the same way. On the other wires I just tapped in and soldered and taped as not to cut the factory wiring.
I hope his helps anyone that might be doing the same swap that I needed to do to get my everyday driver back on the road with a few upgrades.
 

·
Registered
Joined
·
2 Posts
This can help:

for original post search in google:

wiring 1.7L SOHC stock ECU nonVTEC-to-Vtec Swap

I don't know if I can post links from others forums so ... its a direct copy paste
I feel this can help pay back your effort

I just did this my 2005 Civic LX (non VTEC) blew up and replaced it with a 2003 Civic EX VTEC Motor, Trans, wire harness and ECU

Some of the wires are a little different between the 2
There are differences between the Motor harness and the body harness.

All good after flash from Honda
Keys work now with the ECU that matches the motor need to do this if you change the ECU. The motor ran on the LX computer just thew codes for the O2 sensors.
Only code its throwing was the heater on O2 sensor 2 which if you get the harness from the motor there is no place to connect the Downstream O2 sensor as the exhaust is different between the 2 motors. I changed my exhaust also, used a aftermarket LX header back exhaust and just added the 2nd O2 sensor about mid car and left the plug in the header for O2 number 2. You will also need the O2 sensors for the EX motor as they are different between LX and EX
Wired the Black/Yellow wire to pin 5 yel/blu on connector E
Wired all O2 stuff to connector E and all good now, No codes

So just so its cleared up for anyone else doing a LX - EX conversion in a 2001-2005 Civic here is where the wires are landed when using EX Motor, Trans, Wire Harness and ECU

Here is where they are on the stock harness Connector A (31 pins)
25 wht/red Secondary O2
23 brn/yel Logic Ground
14 blk/wht SecondaryO2 sensor heater control
10 grn/yel Sensor ground
Blk/yel Heater acc power

Here is where they go on Connector E (31 pins)

2 wht/red Secondary O2
3 brn/yel Logic Ground (Shield from O2 Sensor)
5 yel/blu Sensor voltage (attach to blk/yel from O2 Sensor)
6 blk/wht SecondaryO2 sensor heater control
Connector A (31 pin)
10 grn/yel Sensor ground

On the wht/red and Blk/wht
I dissected the old harness to get the whole wire with the metal ends that fit into the harness. As you will find out when going from LX to EX there are a few different wires and they are not in both body harnesses the same way. On the other wires I just tapped in and soldered and taped as not to cut the factory wiring.
I hope his helps anyone that might be doing the same swap that I needed to do to get my everyday driver back on the road with a few upgrades.
 
21 - 36 of 36 Posts
Top