Honda D Series Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Ok I bought some one elses project and now im paying for it. Ok the car is a 91 CRX hf with a d16z6 swap. The car runs just as im stating. It starts up great, the idiol surges around 1500-2000rpm. When you rev it up it spudders from 2000-4000ish, than opens up past 4200 like nothing is wrong. It has the xenocron obd1 jumper, 4 wire o2 sen. I read all the internet instructions for this harness double checked map sensor and all that stuff. I also did a tune up, cap, rotor, wires, plugs. Still same thing. I also know my Vtec pressure switch had low resistance when I checked it compared to my buddys d15. I didn't think that would effect the low rpm problem. Im kinda new to hondas and lost at this point any other help would be great
 

·
Registered
94 civic, 90 talon
Joined
·
1,943 Posts
To answer your question truthfully...Chuck Norris. All intake type sensors good? Nothing fuckin with your fuel? Anything wrong with timing? (I don't see timnig being a problem) Sounds like TPS.
 

·
Registered
Joined
·
67 Posts
I've had something similar happen which was caused by a faulty tps. You should check that out. Also there are a few things that can cause the idle surge. You should clean out your FITV and your IACV. Also bleeding your coolant might fix your idle surge problem. This is what cause the idle surge on my car. It happened after I did a coolant flush. Lastly do you have any sort of CEL? And is running a stock ecu?
 

·
Poop Sock
wrx & slut rex
Joined
·
3,798 Posts
clean your iacv. ive done it before..... easy job. its on the back of your intake manifold. google image it so you know what to look for. disconnect the hoses (a little coolant will run out) unbolt it from the IM and get some carb clean and spray the screen. then let it completely dry out and put it all back on.
 

·
Registered
94 civic, 90 talon
Joined
·
1,943 Posts
clean your iacv. ive done it before..... easy job. its on the back of your intake manifold. google image it so you know what to look for. disconnect the hoses (a little coolant will run out) unbolt it from the IM and get some carb clean and spray the screen. then let it completely dry out and put it all back on.
There is totally a DIY thread here for that. Makes life really easy.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
So what would make it spudder at the 2000-4000 range. I know the vtec pressure switch is bad but would that cause a problem in that rpm range.
 

·
Registered
98 Civic EX
Joined
·
3,189 Posts
vtec switch is bad? i thought you said that it was fine?

for idle surge, you have your answer above, for the sputtering look above, also a vacuum leak could cause these problems as well
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
The new tb gasket looked more like the right one. It was kind of weird when I started it up it wouldnt idle at all, but it was still running at like 100 rpm lol. Im wondering if I adjust the idle up if that would make it right.

???
 
1 - 12 of 12 Posts
Top