Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello everyone, i was told to come to this site for some answers.

ive searched for an hour and not been able to find someone with the same problem.

i have a 1996 Civic hatch obd2

recently installed a D16z6
dizzy has been converted to a obd2 clip
Altenator been converted to obd1 clip
obd2a-obd1 jumper with p28

ive check for any leaks on any hoses everything seems to be intact tight.

my problem is when i start the car it high revs at 1500 wait 20 mins obo to warm it up yet it still stays at 1500+ and if it hits 1800 my idle keeps going up and down between 1800 and 2000. usualy stays at that rpm when im driving for an hour or so. some times it would go to normal idle at 1000 but rarley,other than that it stays at 1600+ and its killing my gas

someone told me my ecu is looking for a 2wire not a 3wire. but not sure what they were talking about.
 

·
i save your ass when you wreck
94 hatchback cx
Joined
·
6,693 Posts
i had this problem also...i cleaned my iacv and then took the other idle control unit off the bottom of the throttle body. took it apart. there is a white cap with threads on it. i threaded it all the way in and BAM fixed the problem
 

·
i save your ass when you wreck
94 hatchback cx
Joined
·
6,693 Posts
u kno where ur coolant lines go on your tb? if u unbolt that. (3 10mm bolts) then there is a flat cap with phillips head screws on it. (2 screws) take that off. there is a white looking cap with threads on it in there. screw it all the way down
 
1 - 5 of 5 Posts
Top