Honda D Series Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter #1
My y8 turbo tuned s300 on e85 is all the sudden bogging hard at 3k and i cant barely accelerate. It seems to only be under load at a stop in nuetral i can rev fully. The cel isnt coming on. Im not sure where to start any ideas?

Its been running perfect for months. I do still have the stock headbolts on it could this be head lift? i dont see any oil in the coolant.
 

·
Registered
Joined
·
1,187 Posts
is it under WOT or just under any load?
 

·
Registered
Joined
·
327 Posts
Discussion Starter #4
Its under any load. Its a fresh tank and i havent heard of that.
 

·
()*#$(*$
Joined
·
11,404 Posts
Do you have a wideband?

Have you checked your spark plugs?

Did you change your fuel filter after you switched to E85? (E85 can and does loosen crap up in the fuel system, which can lead to plugging the filter way faster than normal, preventing it from flowing enough fuel to keep up with the demand of engines under load.)
 

·
Registered
Joined
·
1,797 Posts
I had to replace my fuel filter at about 500 miles after switching to e85 because it cleaned all the crap out of my system...haven't had it clog since. I would check your plugs and your fuel filter.
 

·
Registered
Joined
·
327 Posts
Discussion Starter #8
I dont have a wideband. Il try a new fuel filter and plugs tommorow. Thanks for the help guys.
 

·
Registered
Joined
·
327 Posts
Discussion Starter #9
Do you have a wideband?

Have you checked your spark plugs?

Did you change your fuel filter after you switched to E85? (E85 can and does loosen crap up in the fuel system, which can lead to plugging the filter way faster than normal, preventing it from flowing enough fuel to keep up with the demand of engines under load.)

Thanks for the input i didnt know that about e85 i havent changed it since i switched just the injectors and fuel pump.

What am i looking for on the plugs?
 

·
Registered
Joined
·
1,187 Posts
well you should change your plugs eveytime you change your oil really. with your motor being turboed it has to burn a lot more fuel than a factory tuned car would.
 

·
Registered
Joined
·
327 Posts
Discussion Starter #11
Fuel filter ftw! swapped this morning and its running great so far! Im going to do the plugs next oil change also. Thanks for the help guys.
 
1 - 11 of 11 Posts
Top