Honda D Series Forum banner

1 - 20 of 50 Posts

·
Registered
Joined
·
880 Posts
Discussion Starter #1
this turbo is really getting to me....its only pushing 5psi and that like when it wants to......i have redone the charge pipes 3 times....cheaked gaskets couplers and even took apart the exhaust side to check the internal waste gate....im lucky if i even will get 2 in first gear...seems like i dont get 5 till about 3rd gear...on my crx...this turbo was pushing 14 psi when i removed it and am using the wastegate that was with it and thats all im gettin? it seems to have like 3-5 psi on start up before it warms up...but once its warmed up its slow....shit i was faster before...this is the 3rd turbo....and al lthe other boosted great just there lives were cut short....and this one is in way good condition...and its not boosting worth a crap...ne suggestions why?
 

·
Premium Member
Joined
·
5,910 Posts
Little lost here. It has 3-5psi on start up what do you mean by that?? That makes absolutly no sense to me. If this is the 3rd turbo you have a serious problem. Are you sure its not your boost guage? BOV sticking open? Could you possibly have an oil supply problem causing these turbo failures?
 

·
Registered
Joined
·
880 Posts
Discussion Starter #4
first turbo was a hybrid that i purchased and they had put it together wrong...and 2nd one had bad oil seals and this one is fine...min to no shaft play...and on start up like when i go when its cool and i just start it in the morning or after is been sittin it seems to like build boost better....and i dont think it would be the boost gauge cuz it worked fine on other 2
 

·
Registered
Joined
·
880 Posts
Discussion Starter #6
yea i know....its really gettin at me...i have tightend all my clamps and intake mani checked and checked..just d/k y it would be doin this....just new turbo..and the rest stuff is same from other turbo...and had no probs with boosting
 

·
the hard-parker
Joined
·
4,257 Posts
have you checked all of your vacuum lines to make sure there are no blockages, rips, holes, or anything like that?
 

·
Registered
Joined
·
741 Posts
How old are your waste gate and bov?? My buddies sr20det I dropped in, has issues making boost too. I finally go into checking it out, it's a mix between a faulty bov and wastegate. Plus it had some nasty compressor surge due to all of that.

You have me a bit confused. You are talking about making boost. Any where from 3psi to 5psi. Then you are saying 3rd gear is where you might hit 5psi. You are looking at it from the wrong way. It's all about what rpm you are pushing for boost. 3,000 rpm's is 3,000 rpms no matter what gear you are in..it just might take longer or shorter to spool depending on what gear.
 

·
the MAD scientist
Joined
·
2,574 Posts
Are you sure there are no exhaust leaks?
I had a slight leak where the exhaust manifold and turbo mated up, and could not build boost like normal. Turn on the car and feel around in that area for any exhaust leaks (try not to burn youself though)
 

·
Registered
Joined
·
880 Posts
Discussion Starter #13
ill have to check on the exhaust leaks....i know there are some minor ones that i will take care of...but would having this exhuast leaks cause it to not to boost once like warmed up...cuz when the car is cooled of it runs decent and boost fine till its get warmed up just low in boost....i will double check everything again when get out school
 
O

·
Guest
Joined
·
0 Posts
my thoughts:
turn car off. let cool down.
take turbo inlet pipe off. stick finger and manually spin turbo, it shoudl be really easy and you should be able to flick it to spin several rotations by hand before it stops. if it doens't spin this way, turbo was improperly built. bearings could be too tight, thrust bearing could be bad or to thick, shaft not properly seated into housing. see of you can move it in and out. if you can, that's a dead giveway of a bad turbo. it should NEVER move in and out.(that's for fun when the sun goes down and you got your little lady frined over ;) )

good luck
 

·
Premium Member
Joined
·
5,910 Posts
Exhaust leaks could effect the boost but not much. Metal expands when it gets hot so it may be a leak getting BIGGER when it warms up but I seriously doubt it. My manifold has been cracked for months and it still boosts just fine. Infact its leaking so bad its turning my head black and cooking my dip stick lol.
 

·
Registered
Joined
·
1,885 Posts
Bizzar said:
Exhaust leaks could effect the boost but not much. Metal expands when it gets hot so it may be a leak getting BIGGER when it warms up but I seriously doubt it. My manifold has been cracked for months and it still boosts just fine. Infact its leaking so bad its turning my head black and cooking my dip stick lol.
i beg to differ. i had leaks in my ramhorn and took me from 7 to 2lbs. welded up the holes and was back at a solid 7psi

i hate troubleshooting boost leaks
 

·
Registered
Joined
·
880 Posts
Discussion Starter #18
well i seemed to maybe have kinda fixed it...in first gear it will not boost really unless when its like cold....but if im in2nd and gradually push throttle and then kinda get on it i will get boost but it will have hard time like drop and jump back up to about 6....
 
1 - 20 of 50 Posts
Top