Honda D Series Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I recently did some pulls on virtual dyno, not really looking for numbers, just the graphs.

Anybody have any ideas on why I have such a steep fall in torque (and power) after about 5k? I thought the turbo was running out of breath so I turned the boost down but still have the same graph.

Setup:
D17A2 stock block, stock head
50 trim .42/.48 turbo
Log manifold
2.5" downpipe to 2.25" eBay exhaust
500cc injectors
Hondata Kpro running a street tuned basemap. 14* timing at 12 psi


12 psi:
https://drive.google.com/file/d/0B-FHfTSQWmlTVE5DN1ViS0pTb2M/view?usp=sharing

11 psi:
https://drive.google.com/file/d/0B-FHfTSQWmlTcDd3WUlfSG5YNnM/view?usp=sharing
 

·
Registered
same
Joined
·
1,881 Posts
I recently did some pulls on virtual dyno, not really looking for numbers, just the graphs.

Anybody have any ideas on why I have such a steep fall in torque (and power) after about 5k? I thought the turbo was running out of breath so I turned the boost down but still have the same graph.

Setup:
D17A2 stock block, stock head
50 trim .42/.48 turbo
Log manifold
2.5" downpipe to 2.25" eBay exhaust
500cc injectors
Hondata Kpro running a street tuned basemap. 14* timing at 12 psi


12 psi:
https://drive.google.com/file/d/0B-FHfTSQWmlTVE5DN1ViS0pTb2M/view?usp=sharing

11 psi:
https://drive.google.com/file/d/0B-FHfTSQWmlTcDd3WUlfSG5YNnM/view?usp=sharing
I'm gonna say the stock cam might be your issue. Also the log manifold possibly. for high revs, a ram horn would be better but you will see an increase in lag if you do that.
 

·
the artist formerly known as drexelstudent11
Joined
·
3,983 Posts
stock cam for sure... also a lot of power for stock rods, they don't live super long at 225ftlbs
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
I'm gonna say the stock cam might be your issue. Also the log manifold possibly. for high revs, a ram horn would be better but you will see an increase in lag if you do that.
stock cam for sure... also a lot of power for stock rods, they don't live super long at 225ftlbs
Awesome guys, thank you. I thought maybe it was the cam (and IM) but didn't want to cross off the exhaust as being too restrictive or turbo being too small.

A built motor should be going in the car soon, if not a K20. I got ARP head studs and rod bolts on the current one to help out a bit.
 
1 - 4 of 4 Posts
Top