Honda D Series Forum banner

1 - 20 of 37 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Weird one here boys. I have a d16y8 on a edel. Turbo ecu and a simple eBay turbo kit on 7lbs. Car runs fine and builds boost but when I’m at WOT and hitting full boost the car decides to fall up on its face and just stays at 4500 to 5000 rpm and starts backfiring and popping. Any ideas on how to fix this? Car is not in limp mode either
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,713 Posts
who did you have tune it? sounds like fuel cut
 

·
Registered
93 Civic HB SI
Joined
·
929 Posts
"D16Y8 on a edel"? Whats that?

"Turbo ECU"? Was this something you bought from eBay?

What you're experiencing is definitely not weird, especially if the car isn't tuned, and it sounds like you've done nothing to support the turbo.

Start by listing everything you've done, leave no detail out.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
"D16Y8 on a edel"? Whats that?

"Turbo ECU"? Was this something you bought from eBay?

What you're experiencing is definitely not weird, especially if the car isn't tuned, and it sounds like you've done nothing to support the turbo.

Start by listing everything you've done, leave no detail out.
It’s a edelbrock turbo ecu piggy back that splices into the ecu. It has a vacuum line that goes into the actual piggy back to know how much boost the car is building and off that it can self tune, adjusting the afr. The car was boosted before on the same setup but I just don’t know why my car doesn’t wanna boost when it’s at full spool.

FULL MOD LIST
-D16y8
-Edelbrock intake manifold (8 fuel injectors)
-t3 turbo kit off eBay
-blox sandwich plate
- edelbrock turbo ecu piggy back
 

·
Registered
Joined
·
6,261 Posts
Did you ever check valve spring seat pressure? weak springs will cause float under boost.

Try turning boost down if possible and rechecking.

If you cannot, try running up to redline at half throttle, seeing if you can even get it to rev out.
 

·
Registered
Joined
·
6,261 Posts
WAIT, edelbrock piggyback....


Those still need some user input to be used. You cannot expect it to magically work.

I wonder if its detonating its ass off.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
WAIT, edelbrock piggyback....


Those still need some user input to be used. You cannot expect it to magically work.

I wonder if its detonating its ass off.
I thought the same.... I have already tried retarding ignition and still not getting any progress to fix the problem
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
so it ran fine with the ebay turbo kit and then suddenly it stopped running fine?
The owner before me ran the same exact setup and was able to boost up to 12lbs. I even took the car to him and he messed with my timing and what not and the car just did not run right.
 

·
Registered
Joined
·
6,261 Posts
What is the CURRENT spark plug gap set to?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,713 Posts
in? mm? nm? km? mi?
 
  • Like
Reactions: drtalon123

·
Registered
Joined
·
6,261 Posts
0.028 inches, well, it should work.

Could always try checking out fuel pressure before going nuts anywhere else.
 
1 - 20 of 37 Posts
Top