Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My 88 is a 1.5L hatch... So I bought the car for 50$ story is timing belt blew, head was pulled off and checked was good do new head gasket and new belt re installed, car would t start sat for 3 years, aftermarket fuel pump installed and it supposedly started and ran. When I bought it I changed the filter and he has the fuel tank half out and the other fuel pump jimmy rigged so I disconnected the feed like to the pump and ran a hose to a jerry can outside the car just to try to make sure it runs before I throw money at it.... So it will fire and start but dies right away sometimes I can get it running for about 30 seconds but then it dies off again.... Been poking around can't find much, what should I be trouble shooting first? I know the fuel is getting to the intake I pulled the line off and it sprays fuel when the key is on and pumps when cranking, so fuel is good.... I think next I'm gonna pull the plugs and make sure there is strong spark in all 4 cylinders.... After that I don't know, any help will be VERY appreciated
 

·
Premium Member
Joined
·
5,819 Posts
Did you put the motor at tdc on the compression stroke and make sure the cam and distributor are lined up?

Firing order right?

Compression test?

Tps adjusted

Injectors working right

Timing.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3 (Edited)
I didn't do anything yet except make sure the pump is putting fuel to the engine... I wanted ideas on where to start... I wasn't the one to do the timing belt...... On a side note, do you have a 2jz build going on?
 

·
Registered
Joined
·
2,003 Posts
Take out the main relay and resolder the joints on it, it is the big relay behind and the drivers side kick panel/dash.
 

·
Registered
Joined
·
37 Posts
well you know its getting fuel and spark because its starting. its possibly a iacv tps or something to do with the idle.
 
1 - 5 of 5 Posts
Top