Honda D Series Forum banner

1 - 20 of 20 Posts

·
Registered
97 Civic EX
Joined
·
107 Posts
Discussion Starter #1
Does anyone know how to turn the SRS light off? Or know why its on in the first place? Its a 97 Civic EX. Let me know. Is there something I can fix to turn it off?
 

·
Registered
95 ex coupe
Joined
·
4,281 Posts
there is a way to jump with a wire.
il try to find it for ya.
 

·
Registered
95 ex coupe
Joined
·
4,281 Posts

·
Well?
Joined
·
10,814 Posts
that may not always work but it comes on anytime you take the battery put of the car. I know mine was on and i tired to reset it but it wouldn't so something was wrong. Than 2 weeks ago when i wrecked the bags still came out even though the light was on
 

·
Registered
95 ex coupe
Joined
·
4,281 Posts
mine is on from unpluging the airbad.
changed the steering column cause the ignition went out.
tried resetting it like the link i posted. went off but came back on so something is wrong with mine. horn and cruise doesnt work and thats all tied in with the airbag wiring
 

·
Registered
Joined
·
374 Posts
mine is on from unpluging the airbad.
changed the steering column cause the ignition went out.
tried resetting it like the link i posted. went off but came back on so something is wrong with mine. horn and cruise doesnt work and thats all tied in with the airbag wiring
most likely if your horn and cruise dont work and the srs light is on (wont reset) its due to your srs clock spring being broken.
 

·
Registered
97 Civic EX
Joined
·
107 Posts
Discussion Starter #9
horn and cruise work fine. one of the reasons i havent put a new steering wheel on it.
 

·
Registered
97 Civic EX
Joined
·
107 Posts
Discussion Starter #11
i didnt think about the plug under the seats, im pretty sure its not connected. that would cause the light to come on?
 

·
endo_bobo
1998 Civic Sedan
Joined
·
877 Posts
I don't think so, mine wasn't plugged in since I got my car and my light only came on after I changed my steering wheel. But it wouldn't hurt to check.
 

·
Registered
huh?
Joined
·
1,315 Posts
Did you make sure the plug is not damaged behind your gauge's? If you messed up a pin while plugging it in, im sure it could give you problem..
 

·
my name says Guest, but Im really a MEMBER
Joined
·
10,488 Posts
take it to a shop and have the code cleared. I cleared the code on my EK and it has not came back since. A buddy did the same thing on his EK or BMW. Very common for codes to throw, clear them and it never comes back. something could have been unpluged, etc.
 
1 - 20 of 20 Posts
Top