Honda D Series Forum banner
1 - 13 of 13 Posts

· Registered
97 civic
Joined
·
40 Posts
Discussion Starter · #1 ·
My speedometer is actin up, when i cut the car on to acc, the needle jumps straight to 30mph. i unplugged the cluster and the speed sensor to try to reset but it still does it. in other suggestions?
 

· Registered
Joined
·
300 Posts
uh new cluster? my cluster is all jacked up, does the same thing. Jumps around when i am driving and now it doesn't light up at night. lol i just memorized where my rpm's need to be and i go off the rpm's now haha. it has 313k on it so thats why i think its happening, just a bit old..
 

· Registered
Joined
·
300 Posts
hmm dont know what to tell u man. i guess just try to pin point what the exact problem is and go from there. make sure all you sensors work and what not. also do any of your buddy's drive a civic like yours? maybe swap clusters with someone and see if that fixes your problem..
 

· Registered
94 EG6
Joined
·
136 Posts
my speedo is effin haunted!!! once i get to about twenty or thirty mph it just jumps to life... then it wont work then it willl just whenever it wants to... i thought it might bee the vss but then thought again when i started to beat on the dash while running about 60 mph then it would come to life... also there is no pin at 0mph to like stop the needle when i turn the key off the needle just dropss.. sometimes turns counter clockwise too lol alaso it is a 5spd but has no tach and the cel bulb is not functioning so idk if its throwing any codes... any ideas if its the vss or what?????
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top