Honda D Series Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
so...
heres my setup

d16z6 fjt rods and vitara 75mm.
gt25 turbo
greddy manifold
2.5 inch dp.-3inch cutout/exhaust
Front mount
stock head
rc550s
motorola 2.5
hondata s300
10 lbs
vpower gapped to 28

i see full spool by about 3500-4000
but on the dyno where it was tuned they made 160whp/160wtq
the down pipe is pretty shitty but ive been told that shouldnt be the issue.
i went 13.1 in the 1000ft and trust me im a decent driver.

should this setup have yeilded more than that?
i had to replace a headgasket that could have been blown while tuning.
then checked the plugs and it was hella lean (my wideband blew)
so im dumping fuel in there just to richen it up. and its helped alott. but im still confused.
i mean i barely pull a civic with a gsr swap.
im not sure. if anyone could help it would be appreciated



these are my maps.
the boost columns should be rich. but not sure since the wideband is at plx..(i have to keep driving the car for work so i just added fuel untill i hit the gas and a small puff comes out. plugs are looking good as well.




 

·
Registered
Joined
·
698 Posts
Very small turbo,what are the specs on it? My car put down 160whp and 150ft lbs on a small 16g and thats most likely comparable to it.

Also was this on a Mustang Dyno or a Dynojet?

Mine was on a Mustang Dyno
 

·
Registered
Joined
·
294 Posts
This is what I hate people do vitara builds then cheap out on the turbo setup then bitch they are not making any power. Get a decent turbo and manifold and turn the boost up and you should see some power, good luck!
 

·
Premium Member
95 CX Hatch
Joined
·
5,910 Posts
Sounds about right. I put down 197 @ 10psi on a bigger turbo and a stock D15B (higher compression than vitaras). Tiny turbo + low comp + little boost = low hp numbers doh!
 

·
Registered
Joined
·
149 Posts
Discussion Starter #7
well it seems that with my boost controller i can only see a max of like 11 psi. i guess stock wg is like 6psi?
 

·
Registered
Joined
·
149 Posts
Discussion Starter #8
and im not bitching about my build. i was actually happy with it. when i went to the track and went 13.1 in the 1000ft. people came up to me questioning the tune. so this led me to question it as well.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #11
1.8th mile was 10.3ish i believe i seemed to have lost my slip
in the 1000ft i was trapping high 70s and i think 80mph once.
 

·
Curious George
'99 LX Civic Sedan
Joined
·
3,569 Posts
1.8th mile was 10.3ish i believe i seemed to have lost my slip
in the 1000ft i was trapping high 70s and i think 80mph once.
Something go wrong with the power output or the traction, I've made 9.9 on 1/8 and I'm still naturally aspirated.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #14
im running 195/55/15 i believe. on the 04 ex fat 5 look alike wheels.
z6 tranny manual
stock flywheel
stage3 clutch
yeah. there was a guy there who was running the same setup on a stock z6 with afc tuning at 6 psi. and went 12 flat in the 1000ft.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #19
on those fat wheels and fuzion vri tires lol. i could2.1s keep in mind this is the first time at the track with this setup. which i think its decent btu shouldnt have yeilded that slow of a time.
 

·
Registered
Joined
·
4,732 Posts
10.1 1/8 mile.. with 160whp.. should be faster than that. i got 9.9 on a z6 with IHE back in the day.
 
1 - 20 of 38 Posts
Top