Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9,921 Posts
Discussion Starter #1
I dont get it... now my car is not runinng right at all... at highway speeds(60-75) it stumbles and sputters and while at low rpms, rolling speeds it dies..... what could it be? I replaced the dizzy about 2 years ago with a new one.... bad plugs?
 

·
Registered
Joined
·
5,015 Posts
check plugs, compression, any afr readings?
 

·
Registered
Joined
·
9,921 Posts
Discussion Starter #5 (Edited)
I just installed a new Fpr.... i put set it at 42psi with the vac line off and its def been running worse after I put that in....
 

·
Registered
Joined
·
9,921 Posts
Discussion Starter #7
How do your plugs look? I wonder if you're running super rich. Do you have a wideband? I would check grounds also.
I think I found the culprit.... on top of the FPR... the little o-ring that seals the top, where you adjust was twisted and it was leaking pressure.... so that makes sense.... after I fixed that.... I drove it... much better..... Only time will tell regardless IM having my local tuner do a re-tune..... next fri
 

·
Registered
Joined
·
2,560 Posts
When are you putting the new kit on? Hope shane can book me for aug 21st. Otherwise I'll just have to go to LJ at Full Blown Motorsport.
 

·
Registered
Joined
·
9,921 Posts
Discussion Starter #9
When are you putting the new kit on? Hope shane can book me for aug 21st. Otherwise I'll just have to go to LJ at Full Blown Motorsport.
yeah man, I wanted to talk to Shane today but he was so busy.... he was tuning a White 92 NSX turbo..... :) The Go-autoworks bullseye in the spring of next year.... I still have to do my damn brakes too and suspenion b4 I can go faster..... grrrrrr
 
1 - 9 of 9 Posts
Top