Honda D Series Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
My car is jumping in idle at very random times, however it displays no check engine light. At times it jumps so drastically that the engine nearly shuts off. So far I have changed and cleaned the idle air control valves as well as changed out the EGR valve.
I am running out of ideas, could it possibly be a...
vaccum leak?
throtle body gasket leak?
intake manifold leak?
throtle position sensor?
Any suggestions would really help me out.
 

·
They call me Awesome!
Joined
·
4,447 Posts
^That. After that I'd start looking into TPS sensor and vacuum leak (Doubt it's going to be that jumpy with a vacuum leak).

Have you removed any ground wires/wiring plugs anything like that recently? possibly a loose connection?
 

·
Registered
Joined
·
73 Posts
Discussion Starter #4
i tightened down all grounds and checked for leaks and i even replaced all my vac lines when i did my build i suspected my tps but i don't know i have another throttle body that i am going to throw on it and ill see if its that. thanks guys any other ideas help to keep them coming
 

·
They call me Awesome!
Joined
·
4,447 Posts
Also check to make sure your Idle screw (Flathead screw in the top of your throttle body) is tight. Mine has wiggled it's way loose a couple times to do this.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
ok so it turned out that my FITV was the problem it was all gummed up but now its running a lot better. thanks guys for all your help.
 
1 - 7 of 7 Posts
Top