Honda D Series Forum banner

1 - 13 of 13 Posts

·
The Great Weldini
91 civic
Joined
·
8,901 Posts
Discussion Starter #1
ok so i dropped in my Exospoeed stage 3 cams in. button everything up nica, nica... started the car. it sounded mean but i turned it off and what i notice still no oil going into the head... so my question here is:

can i replace my oil pump with out dropping my engine?

cause in truth i went thru everything and i still can figure why my head isn't getting any oil. i know i went thru everything except my oil pump. so i had my car towed home. i'm going to drop the oil pan and see. i know i didn't spun a bearing cause my cylinder walls looked like they did when i button it up the first time. i haven had any knocking.

i'm just worring that my rods may be blue. then i'm fucked. lets hope not. *fingers cross*

so any pointers please help a mofo out...


ready to be button up...

 

·
The Great Weldini
91 civic
Joined
·
8,901 Posts
Discussion Starter #3
take the timing belt and gears off, take the pan off, unbolt the pump, and then inspect it.
do you have any oil pressure?
don't know light didn't go off
oil light work or have a gauge?
i know it works i have a gauge but my oem oil cooler makes it a bitch to put my aftermarket one.
 

·
No Tune No Life!
99 Supercharge Regal
Joined
·
2,045 Posts
do you have any oil pressure?
don't know light didn't go off
oil light work or have a gauge?
i know it works i have a gauge but my oem oil cooler makes it a bitch to put my aftermarket one.
If you light did not go off i would say its safe to say you have no pressure. time to pull the pump! pm me if you have and questions.
 

·
Registered
See above...
Joined
·
13,322 Posts
Man Remo, this sucks. When you drop the pan look for discolored (excessive heat) rods and excessive play in the rods on the crank. Did we not install a new oil pump on this build?
 

·
Classic Man
Civic
Joined
·
16,355 Posts
take off the crank pulley, drop the pan, unhook the pickup, take out the 10mm oil pump mounting bolts, slide it off.


easy peazy :p

plus it will give u a chance to check out the rods/bearings
 

·
The Great Weldini
91 civic
Joined
·
8,901 Posts
Discussion Starter #7
If you light did not go off i would say its safe to say you have no pressure. time to pull the pump! pm me if you have and questions.
i'm cool i was trying to figure this out.. thanks for the help..

Man Remo, this sucks. When you drop the pan look for discolored (excessive heat) rods and excessive play in the rods on the crank. Did we not install a new oil pump on this build?
yes we don't you remember dan?
new oil pump and water pump


i'm hoping there's no discolored on the rods... i will be porting this one i will say that up front.
 

·
Registered
See above...
Joined
·
13,322 Posts
No, I couldn't remember what we did. LOL But I'm hoping just for some sort of blockage in there. Very odd though.
 

·
The Great Weldini
91 civic
Joined
·
8,901 Posts
Discussion Starter #10
yeah i know. i called auto zone and advance they wat $145 for a pump. fuck that i'm picking up a ebay special for $70 wait a couple of days and port it when it comes. i have a ultra-sound so i'll clean it that way after i'm done. just need to pic up some devcon.

oh shit i just remember chris at valentine has my other oil pump. i'll go and pick it up in a few. lol.
 

·
The Great Weldini
91 civic
Joined
·
8,901 Posts
Discussion Starter #13
1 - 13 of 13 Posts
Top