Honda D Series Forum banner

1 - 11 of 11 Posts

·
Banned
Joined
·
3,673 Posts
Discussion Starter #1
Anybody ever rebuild a solenoid?
where do i get the kit from?
I saw one on the Jegs website, but im not sure if its the right one.
i ran my kit over 1100 psi, and the seal is protruding
 

·
Registered
Joined
·
292 Posts
take the top nut off both fuel and nitrous solenoids

lift the electronic part off the nitrous solenoid, remember the order on the 2 washers

use both nuts locked together to back the plunger housing out,

remove the plunger from the housing
becareful not to lose the spring on top of the plunger,

at this point you should be able to see the part of the rubber that is protuding
from my expreinces you should be able to just press the rubber that is sticking out back in and reassemble (worth a shot might save some money)

test with car not running and see what happens


ps if you decide to get another solenoid get a "Cold Fusion" solenoid, they are cheaper and much better quality than the "NOS"
 

·
Banned
Joined
·
3,673 Posts
Discussion Starter #9
take the top nut off both fuel and nitrous solenoids

lift the electronic part off the nitrous solenoid, remember the order on the 2 washers

use both nuts locked together to back the plunger housing out,

remove the plunger from the housing
becareful not to lose the spring on top of the plunger,

at this point you should be able to see the part of the rubber that is protuding
from my expreinces you should be able to just press the rubber that is sticking out back in and reassemble (worth a shot might save some money)

test with car not running and see what happens


ps if you decide to get another solenoid get a "Cold Fusion" solenoid, they are cheaper and much better quality than the "NOS"
i have the solenoids apart already....there are little circular shapes in the top of the plunger..any pics of bad or protruded seals?
 

·
Registered
Joined
·
292 Posts
sorry i dont have any pics,

i just took a good one apart because we were talking about this,a good solenoid has a black rubber piece with a single circle in the middle...

if its protruding you can visibly see part of the rubber on the side coming out from the metal seem on the side,

ive heard that if you wait 2 or 3 days the rubber contracts and goes back to normal, ive never been that lazy i just forced it back in place and it worked

so if its sealed all the way around time possibly fixed it.

question, is it not opening? or is it stuck open?
if its not opening thats when i repair them this way, but the first time they stick open is when i toss them in the trash.
 

·
Banned
Joined
·
3,673 Posts
Discussion Starter #11
i am reinstalling after years of sitting...but IIRC there was no activation, and i thought the seals were bad...i will reassemble, and test them out. If they click, they work right?
 
1 - 11 of 11 Posts
Top