Honda D Series Forum banner
1 - 7 of 7 Posts

·
Registered
92 civic dx
Joined
·
84 Posts
Discussion Starter · #1 ·
Ok did a search and nobody else seems to have this problem....i have had nothing but problems from the parking brake since i swapped the discs on. Setup came off a abs 4dr lx or ex. My vehicle is same body 4dr.

The problem is the parking brake has never really worked. I'm constantly having to adjust the cables to keep it just barely grabbing. I'm now near the end of the adjuster and halfway up the lever just stops hard....and the brakes still barely grab. when i did the swap i checked the cable movement and connection...all was good then about a year ago. the calipers are the same...about a year on rebuild no rust when i got them. i believe the arm movement is normal on both....and i believe i correctly rebuilt the piston assembly.

Is it possible the cables are just old and just stretch every time i pull on them? Even if that is the case..why does the lever come to a hard stop only halfway up now? it's quite irritating not having a functional parking brake.

any help is appreciated.
 

·
Tape-R taper/driver
EC3, ED8, ED9, EE5
Joined
·
574 Posts
Have you checked to make sure the piston in the rear caliper is extending when you move the lever actuator on the caliper?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
or that the cables arnt stretched or bound up?
 

·
Registered
Joined
·
3,315 Posts
"When in doubt, throw them out"

Calipers and cables are cheap just replace them all.

There are after-market parking brake cables now
 

·
Registered
92 civic dx
Joined
·
84 Posts
Discussion Starter · #5 ·
First...out of order...lol...when you say cheap i see expensive. i had to save for four years just to get the parts from the junkyard. Another year until i could rebuild it all. Second when i rebuilt the calipers....i checked the movement of the piston as i pulled the lever on the caliper... everything seemed to function fine. Now that's not to say something didn't go awry after some use..we all know how that bit goes. I figure the mechanism is pretty simple...so assuming the calipers are functioning correctly the brake should work fine? All that could b wrong at that point is the cables right?
Another question i have is how strong is the parking brake with the discs? Is it comparable to the drum setup? Should the discs b able to lock up the back with just the handbrake alone while in motion? I remember the drums i could lock up the rears...break the back end loose...but the discs have never come close....they won't even slow my momentum when rolling.
I am certain the hydraulic portion is functioning correctly however...my braking power is much better than when i had the drums and the pads are wearing like normal
 

·
Asshole
Joined
·
4,112 Posts
Installation error or using wrong cables.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
replace the cables and see. check for binding. have you put the car in reverse and as you roll backwards, pumped the brakes?
 
1 - 7 of 7 Posts
Top