Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
So my I bought my car w/ the antenna broken. So I recently installed a new one & it worked fine. But just recently it just stopped working. I can't catch any radio station period. Idk if its the antenna or the deck just sucks. I have a Sony explod idk which one but its pretty run downed. It also recently stopped playing CDs. It takes it in & plays but no sound. I'm new to aftermarket decks or should I say new to sounds period! Idk if this is a common problem or not.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Lol I do, well I have no choice since my deck sucks lol. No aux or USB port, just the simple radio & cd. What do you mean powered antenna? My friend guys are telling me to just ditch the antenna and throw on a block off plate. But I love listening to the radio, especially since I live on hawaii & enjoy the island jams. So a radio is a must for me. So there's no fix to this problem? Just get a new deck?
 

·
Registered
HONDA
Joined
·
1,221 Posts
Lol I do, well I have no choice since my deck sucks lol. No aux or USB port, just the simple radio & cd. What do you mean powered antenna? My friend guys are telling me to just ditch the antenna and throw on a block off plate. But I love listening to the radio, especially since I live on hawaii & enjoy the island jams. So a radio is a must for me. So there's no fix to this problem? Just get a new deck?
Antenna block off plate and look up a marine antenna they work great


Sent from AutoGuide.com Free App
 
1 - 5 of 5 Posts
Top