Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Hello everybody,
got new problem with ECU P28 civic coupe 96
week ago i just start the car and the rpm start making idle problems 700-1400 rpm its just jumping between
i have tried replace the IACV but its not the problem...
after some hours i took another p28 and with the same chip and its fine...
so its ECU issue,i opened the ecu and not found anything burn or something like that,
is there any possible way to check the IACV circut in the ecu? someone know maybe?instead of start to replace every transistor

maybe some idea? connect +12 and check the circut or something?
 

·
Registered
89 EF 4wd sedan
Joined
·
578 Posts
I haven't heard of that problem being associated with the ECU. These problems can come/go with engine temp/ambient temp for example due to the way the wax valves and springs are affected. I wouldn't discount that it could still be something related to the IACV or the TB. Was the second IACV known to be working good? Did you reuse the IACV gasket when you swapped them over? Sometimes they air leak and cause problems.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
I haven't heard of that problem being associated with the ECU. These problems can come/go with engine temp/ambient temp for example due to the way the wax valves and springs are affected. I wouldn't discount that it could still be something related to the IACV or the TB. Was the second IACV known to be working good? Did you reuse the IACV gasket when you swapped them over? Sometimes they air leak and cause problems.
ii have tried the new and the old iacv,
the problem is the ECU 100%
 

·
Registered
93 DelSol S, 95 DelSol Si, 01 Odyssey EX, 04 CRV EX
Joined
·
2,172 Posts
did you replace the whole IACV?

you say an obd1; but a 96.... what is your engine/config? (what style of IACV?)

If its the obd2 style IACV; and you only replaced the electrical portion; the physical valve can get gummed up and cause a whole slew of running issues.... most people only replace the electrical portion for some reason...
 

·
Registered
Joined
·
3,098 Posts
Take that dumbass valve and block it off, move the stop and idle screw out on the TB. Runs so much better without..


. we are all driving "race cars" ... right?


hahahah
 
1 - 6 of 6 Posts
Top