Honda D Series Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
I have a 1996 civic dx hatch that I swapped a d16y8 from a 98 ex and I’ve had some problems with o2 sensor secondary and the knock sensor and this evap code / sensor due to different evap canister. Also an idle air system code. Which the car does surge a little.
so far ive wired in the secondary o2 sensor and that code has went away now I have a remaining of 2 codes the p0453 and the knock Sensor and some times the idle air code.
today I changed the canister for a 00’ hx civic they looked almost identical from the one that was in the ex I took the engine out of. And now that I can actually plug the pig tail into something I’d figure the code would go away assuming the sensor was good but I still have the code. Any suggestions. From some research I’ve done people say it’s the o2 sensor but I don’t have any codes for o2 but it does have me thinking Since I had to manually wire it in to ecu. Or maybe sensors bad.
oh it also smells really bad of gas.
 

·
Registered
Joined
·
14 Posts
Have you tried doing a smoke test to look for leaks in evap system? I have a mini me swap in an 96 ex that we had to have computer reprogrammed to make sure we didn't get codes because of the different sensor setups. Our motor is 96/99. Just a thought I figured I would mention.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
Have you tried doing a smoke test to look for leaks in evap system? I have a mini me swap in an 96 ex that we had to have computer reprogrammed to make sure we didn't get codes because of the different sensor setups. Our motor is 96/99. Just a thought I figured I would mention.
Not yet but I’ll give it a shot thanks. Where should I hook it up too
 
1 - 4 of 4 Posts
Top