Honda D Series Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter #1
I ported out a new pump and took out the 10mm allen plug on the side. I reassembled it with a ptfe sealant which was the wrong thing to do. I took the time to remove the pump, take out the plug, and clean everything. Now what do I put on the threads? It isn't a tapered plug so it won't tighten up. You just have to screw it in until it's fully in there. I have some ideas of sealants to try but I want to hear from everyone that has experience with it.
 

·
Premium Member
90 crx si/96 accord
Joined
·
788 Posts
Pic of the plug.

Is it a set screw type plug, or similiar to an oil pan drain bolt plug?

It's been a while since I've had an oil pump in my hands
 

·
Registered
Joined
·
1 Posts
I ported out a new pump and took out the 10mm allen plug on the side. I reassembled it with a ptfe sealant which was the wrong thing to do. I took the time to remove the pump, take out the plug, and clean everything. Now what do I put on the threads? It isn't a tapered plug so it won't tighten up. You just have to screw it in until it's fully in there. I have some ideas of sealants to try but I want to hear from everyone that has experience with it.
I used Honda bond to re seal mines. Just don't overdo it, excess Honda bond will become hardened and plug oil galleys.
 

·
Registered
Joined
·
284 Posts
Discussion Starter #11
I ended up using permatex high temp red which should be the same as 272. So far so good. I will update if it fails.
 
1 - 11 of 11 Posts
Top