Honda D Series Forum banner

1 - 4 of 4 Posts

·
Registered
Turbo Ford Ranger
Joined
·
21 Posts
Discussion Starter #1 (Edited)
D16y7 engine with y8 head swap. Soon after the swap I've had p0132 code pop up. I've then tough it might be dead so I've ordered the correct o2 sensor for an y8 engine.

I am still using y7 engine harness and noticed the y8 o2 sensor doesnt have the same colors at the same pins, and that the plug is is a female vs the male of the y7 sensor, which isnt a real problem to just solder the male back on.

On the y8 sensor(left) The two black wires are on bottom of the plug while on the y7 they are on the top..

I am just wondering if by soldering the old male connector and switching the colors to fit y7 sensor plug will work or if its the whole y7 harness that isn't wired the same for a y8 o2 sensor and if theres mods to be done to everything..

New O2 sensor I have is Denso # 234-4733.

I know this isn't clear question pardon my english but hopefully someone might understand my question...

How do I rewire it to work properly? :3dtard:

2000 SE civic with 2000 p2p ecu and stock y7 harness... y7 to y8 sensor change..
Thanks.
 

·
Premium Member
Joined
·
5,819 Posts
There wired the same. You have the plug on the right of the pic upside down.

Black to black

Black to black

White to white

Green to blue.

The black wires don't matter which black wire you put to black wire.
 

·
Registered
Turbo Ford Ranger
Joined
·
21 Posts
Discussion Starter #3 (Edited)
No it isn't upside down . Look both white wires are on the left. Like I said the one on the right is a male connector and the newer one is a female.

I just wanted to know if the both black were there same, looks like ill switch the male connector onto my new o2 sensor. But it is pretty weird isn't it that it's supposed to be fitting for a 99-00 y8 civic and it's got the wrong connector and wired upside down.. Whatever.. Maybe y7-y8 sensor plugs are different.. And this could be cause of the o2 code popping up?
 

·
Registered
Turbo Ford Ranger
Joined
·
21 Posts
Discussion Starter #4
you were right it was upside down and since it was female it was inversed. seem to have fixed it. thanks
 
1 - 4 of 4 Posts
Top