Honda D Series Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
ok i have a 96 civic hatch that ever sence i had it was verry lacking in power even for a stock civic, i thought maybe the engine was tired so i took an engine out of my project car and put in the other. when it was on the old car it would fly, now it is working like shit again. changed the cat, the exhaust and everything. fuel filter and went as far as to change the engine harness. i gave up on that and built a y8 with a set of high comp pistons. thinking this would solve my problem. car starts off strong through first and second gear but suck holes after that. in third right to the rug it wont eaven brake the 145km mark. also any slight grade of a hill you have to drop back to 4th or 3rd just to maintain speed. also i might get 350 to 400 km to a tank of gas. i have new 02 sensors and eaven went to obd1 to compensate for my check engine lights. any ideas?
 

·
Registered
Joined
·
4,732 Posts
has it been to a dyno anywhere? or even datalogg/street tune?
 

·
Registered
Joined
·
102 Posts
Discussion Starter #3
none of those around where i am at. there will be in a month but i cant wait that long. if it keeps eating gas like it is i will be better off driving my camaro
 

·
Registered
Joined
·
102 Posts
Discussion Starter #6
i have the p28 obd1 ecu out of a 94 civic. and yes the y8 is in the car now, total re build with a set of d16a6 pistons in it. and i get walked by 93 hatch with a z6 and 300k on it. oh yea i had the fuel pressure tested and it was at spec.
 

·
Registered
Joined
·
4,732 Posts
so its just a Z6 ecu(p28) no chipping at all and ur running a Y8 with it? I thought Y8 and Z6 tables were pretty diff? and you couldnt do that? like ig timing an shit needs to be adjusted?
 

·
Registered
See above...
Joined
·
13,322 Posts
So you have a complete Y8 in the car? Y8 head & block? and you're using a "Z6" ecu? You're timing will be off my friend!
 

·
Registered
Joined
·
102 Posts
Discussion Starter #9
realie. i had thought they were close. i had run inyo the prob wiyh the ftp sensor and also my second o2 sensor. so i was told i should go obd1. it worked about the same but just without the engine light. also i have no vetec and if the revs are above 5300 for more than a cupleof sec the check engne light comes on with a code 22. and no vetec. so are you saying i should chip my p28 to use y8 maps?
 
1 - 10 of 10 Posts
Top