Honda D Series Forum banner

1 - 5 of 5 Posts
T

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I have completed the ZC swap into my 91 CRX SI. I'm getting spark but no fuel. My fuel pump was working fine before the swap. I know my fuel pump just didn't go bad all of a sudden. Everything seems wired correctly. I wired the distributor and crank sensors correctly. Everything seems to plug in whre it was suppose to. Is there something that I'm missing?

Please Help
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #2
your fuel filter could be plugged. im not sure. otherwise probley somthing wrong with your injectors. but im not sure.
 

·
Registered
Joined
·
35 Posts
If your injectors are a question then put your old ones in it unless you had the DPFI engine then never mind. His fuel filter would not have suddenly plugged up.
What ECU are you using is it the one you already were using? If not try that one if it's an Si and see what happens. The transistor that turns on the fuel injection relay could be bad in the ECU that you using. I would try another ECU if everything else is already correct.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I'm using the same ECU that was in my car. I loosened the two banjo nuts on my fuel filter and no fuel is coming up to that point.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Fuel problem solved. It was the ground wire that connects to the thermostat. But now I'm not getting any fire. Are all swaps this difficult. I just want to get this thing started. I'm tired of not being able to drive my car. Any suggestions please?

Thanks for all of your help
 
1 - 5 of 5 Posts
Top