Honda D Series Forum banner

1 - 11 of 11 Posts

·
D-series child
Joined
·
326 Posts
Discussion Starter #1
So last night at the track I noticed my bottle pressure gauge wasnt reading, yet the nitrous was working... very well.. :lol: There's no clogs or anything in the way of the hole. What can be causing it? Did I get a bad one?

Also, When disconnecting the nitrous line I found that air was coming from the hole beneath the gauge. Do I need to plug this up or is this gauge a lemon? I didnt drill nor make that hole. Pic below.

 

·
Registered
Joined
·
66 Posts
i have alot of fittings like that it shouldnt have anything comming out of it you might need to tighten it up a little better. but it sounds like you have a lemon. the gauge would read some thing even if it was letting some out though that hole
 

·
D-series child
Joined
·
326 Posts
Discussion Starter #7
shitty install.
what are you talking about?

i have alot of fittings like that it shouldnt have anything comming out of it you might need to tighten it up a little better. but it sounds like you have a lemon. the gauge would read some thing even if it was letting some out though that hole
Yeah, Im not sure. I put teflon paste around the gauge, so Im sure its not leaking, but while disconnecting the line air was hissing out of that hole. Should I take it back and get a new one or what?
 

·
Registered
Joined
·
2,192 Posts
what are you talking about?



Yeah, Im not sure. I put teflon paste around the gauge, so Im sure its not leaking, but while disconnecting the line air was hissing out of that hole. Should I take it back and get a new one or what?
well if there is pressure and the gauge is showing 0, then yes take it back.
 

·
Brokedick Millionaire
Joined
·
40,227 Posts
IIRC, those little holes are for safety wiring.

Once you broke loose the conection, the little holes were easiet exit.
 
1 - 11 of 11 Posts
Top