Honda D Series Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter · #1 · (Edited)
This is pretty interesting so i thought i would share. I went to the dyno to get another tune today with my new setup consisting of a fresh p&p and a new edlebrock header (from ractive header). The last time i was their i made 133.1 hp and 102.5lbs of tq, this time i only made 125.6hp and 107.7lbs of tq. So i lost 8 peak hp and gained 5lbs of tq. for the $800 i spent on the head i was a little disapointed. It almost seemed like it was a diffrent motor under the hood, we had the cam gear @ 2* advanced and we had to bring it back to 2* retard, the power curves were diffrent and the fuel was way off. Im not sure what to really think about it except that i think the head was over ported. It was done by KMS engine development so watch yourself their. But i did pull down 190hp with the gas, last time i made 174 BUT i had a leaking head gasket, so we dont know if i gained power on the nitrous. It is what it is i guess. i sucks but thats car building i guess
 
  • Like
Reactions: vtec-e94hatch

·
Registered
Joined
·
3,431 Posts
It could be over ported for your set up without the spray...You might just not be pulling in enough air without it...
 

·
The H Badge is it!
91 crx
Joined
·
5,657 Posts
or maybe its the edelbrock header... they arent exactly the best for a honda..
 

·
Registered
Joined
·
822 Posts
Am I reading this correctly? Is this a NA topic in the FI section?

Edelbrock does some great stuff but I don't think they aren't really focused on the SpoCom world... Honda's or not...
 

·
Registered
Joined
·
283 Posts
Discussion Starter · #11 ·
Read my post again, This time read the whole thing carefully
 

·
i shoot stuff
Joined
·
2,422 Posts
i dont think the header is the reason for the problem

i say the cam and tunning

what are u running for management
 

·
Registered
Joined
·
283 Posts
Discussion Starter · #15 ·
I have the s200 for tuning. My tuner mark was one of the first dealers for hondata(turbo tune) years ago. He has been tuning cars forever and has an excellent reputaion in the carolinas, He really couldnt tell what was going on we spent alot of time trying diffrent things. He said it was like a completely diffrent motor under the hood from last time we tuned. As for a cam i already have the zex 59300 camshaft and everything else in my sig.
 

·
D-series Janitor
Front Engine Dragste
Joined
·
1,220 Posts
I had the same problem with my head . . .

I ported a pm9, intake went 226 @ .550" and exhaust went 195 @ .550" (both at 28" of h20). Air flow picked up all the way across the board.

Milled .030", switched to a y8 HG (compressed .038), delta 260 cam and only picked up 11whp. The cam is at 8* retarded (interesting . . .) and full timing.

I made 95whp before all that and the first pull after made 93. I was extremely disappointed, expected around 115ish.

Sorry to hijack but I thought it was interesting to see someone else have a ported head only to lose power or not pick up as much as you initally thought.
 

·
Registered
Joined
·
5,015 Posts
you can't run stock compression and a small 59300 on a quality ported head. of course you're going to lose power.

drop some p29s and a crower 3 in, then report back.
its a HDM d15b no p29's wont work.

either civic GX pistons of cutum from weisco.
 
1 - 20 of 29 Posts
Top