Honda D Series Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
685 Posts
Discussion Starter #1
so, i finally finish my car after 3 days modding the dp piping mounting up everything wiring EVERYTHING up. Make a base map for my car. started up let it idle around 15.3 +-.2 : 1 for bout 20-30 mins trying to let the air come out of the coolant and i double check for leaks and i come to find my turbo is leaking on the turbine housing....

i tap the gas and sure thing smoke comes out of my exhaust. i knew it would be the turbo because i NEVER smoked N/A...

this sucks cause i bought the turbo from a friend i thought i could trust... he said it was fine and he pulled it off cause he stripped the turbine housing dp bolt holes... i said sure i'll buy it off you and get it fix.

turbo had min. shaft play. no in and out, but some side to side. maybe .5 mm shaft play? still seemed tight....

any ideas of what it could be? most likely the seal, but i'm hoping for something alot easier of a fix..

sorry, just wanted to vent bout this... this sucks...............................
 

·
Registered
Joined
·
685 Posts
Discussion Starter #2
also have a remote mounted - 4 AN line to a T. that goes to my oil pressure sender and a -3 line to my turbo. which i have a restrictor on... and a -10 or -8 stainless line to a return on the pan.

i know people might say i don't need the restrictor, but it came with the return and i didn't have a fitting to go onto the turbo.... think if i remove the restrictor it would help? lol

turbo is a precision sc32. forgot to mention that.
 

·
Registered
Joined
·
6,365 Posts
Pix of the drain? Maybe its not draing all the oil good enough. But it could also be seals. Does it pour a ton of smoke out? And does it have liquid oil coming off the turbo?
Because a small flow could mean it just needs to warm up.but a heavy flow would be seals.
 

·
Registered
Joined
·
685 Posts
Discussion Starter #6


i'm using a -10 AN drain i think. that or it's -8 AN it's big. and -3 feed with restrictor. idk how to tell what size restrictor i have. is there any kind of stamp etc on them? does anyone know?

might try to remove the restrictor and see if the leak becomes worst. if it does then that will be for sure the seal, but i don't want to risk damaging the shaft...
 

·
Registered
Joined
·
685 Posts
Discussion Starter #8
I used 5w-30 supertech for now. The turbo is not completely vertical with the feed and return. Guess I'll pull the drain and crank the motor to see if the oil is coming out Ok before I try to reclock the turbo.
 

·
Classic Man
Joined
·
16,355 Posts
to me it looks like either your oil feed or oil drain flange is loose. the feed looks loose for sure because the turbo is oily above the drain...

those feed flanges are known to snap if u try to tq them too much..
 

·
Registered
Joined
·
685 Posts
Discussion Starter #10
to me it looks like either your oil feed or oil drain flange is loose. the feed looks loose for sure because the turbo is oily above the drain...

those feed flanges are known to snap if u try to tq them too much..
maybe you're right. i didn't see that till i looked at the pictures again where the oil is coming down from the side...

but would the oil be able to seep into the turbine housing and cause it to smoke?

and i didn't put any kind of rtv or anything like that on the flanges before putting them on. there is a gasket on the return flange and i tighten the bolts pretty tight.

the top might not have sealed correctly now that i think bout it. think there was some rtv i didn't remove.
 

·
Registered
Joined
·
685 Posts
Discussion Starter #11
so i replaced the restrictor with a regular 1/8 to -3 an fitting at the feed of the turbo. to rule out the oil is leaking at the top to the bottom. that part is now NOT leaking.

the return i took out the 45 degree at the return fitting and replaced it with a straight fitting. now i have the 45 degree AN bend at the oil pan at the turbo return part.

the turbo doesn't leak as bad now, but still the same. the return line looks more "downhill" now. with less straights. might try a rubber line if i can find one.
 

·
Registered
Joined
·
685 Posts
Discussion Starter #12
so i said f it. left everything like it is. said "if it's gonna leak let it leak. gonna have fun with this shit."

went out, went for a few pulls with my basemap. came back. let the car cool down. and BAM! no more leaks!

my wastegate was set at 3 psi. guess the pressure build up at the turbine housing pushed the seal apart and stopped it from leaking. car was sitting for 30 mins idling with no leaks.

guessing without the restrictor and redoing the return helped the leak as well. thanks again guys!
 

·
Registered
Joined
·
852 Posts
Does it still smoke? I have a similar issue, rebuilt turbo, great drain line, running restrictor. Except mine has been boosting for 3-4k miles and still smoking and burning oil
 

·
Registered
Joined
·
685 Posts
Discussion Starter #17
ya i would make the drain as short as possible.

mine is still holding up. my oil level is staying the same. and i'm not smoking in or out of boost.
 
1 - 17 of 17 Posts
Top