Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I just finished putting in my new engine which is a d16y7 block with d16y8 head. Motor has jackson blower on it. There is more but I don't think it pertains to my problems. I have a vacuum leak coming from the line off the black pcv box going into the intake manifold. Also the car has no power, meaning if I even touch the gas it sputters, misfires, and will not go. I'm also getting some smoke out of the exhaust which seems to be oil. Now I saw this motor run in the car it was in before mine and had no oil issues. However my last motor I crack two piston rings and was pushing a lot of oil out before I removed it, not sure if its left over oil in the exhaust or could somehow be caused by the pcv issue. I am running a Kenji Ecu if that makes any difference. Im sure I could be more helpful but for now this is the best way I can explain it. BTW this is the first motor I have tried to use this ecu on, my other was a stock ecu. Car will not even drive up a hill. Thanks for your time and patience reading this...Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,217 Posts
what size injectors are u using, and is the blower internally oiled, or does it receive oil from the block?

any cels?

maybe the cam is off a few teeth.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
injectors are 450's I believe, the cam is not off and the motor is in time, Im using a JRSC. Don't think the injectors really matter cause I dont even have a chance to get into boost.
 

·
Registered
Joined
·
1,217 Posts
what injectors are they? are they dsm? did u use a resister box if they are dsm injectors or other type that are high impedance that require the use of resisters?
 

·
Registered
Joined
·
713 Posts
also is your kenji ecu setup to run the 450's? check to see if you have the map and tps sensor plugs mixed up.
 
1 - 6 of 6 Posts
Top