Honda D Series Forum banner

1 - 7 of 7 Posts
J

·
Guest
Joined
·
0 Posts
Discussion Starter #1
i have a 90 crx si. I used the D16a6 block with the 96 Y8 head and manifold
the camshaft/gear is a z6 one. the problem i am having is it will not rev past 5 and when i try to it feels like it hit a rev limit and the rpm drops while i push the pedal down. i did not use the black vacume sensor on the back of the y8 manifold...i think its called the EVAP sensor...because the crx harness does not have a plug for that sensor. i replaced everything with new parts. timing belt/water pump/plugs/wires/cap/rotor/headgasket/fuel filter. im using the y8 ruel rail and z6 fpr. and im using the z6 throttle body.

it drives normal up to 4 to 5 grand...but if i floor it and shift b4 4 it bogs right at each shift...everything is on tdc.. head and crank

need help asap!!
 

·
Registered
Joined
·
4,363 Posts
how in the world did you use a z6 fpr on a y8 fuel rail? The hole for fuel does NOT line up.. that must be your problem... no fuel.... i can't believe it's not leaking either.

get a y8 fpr...
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #4
^^ dr mack is right. and yeah what ecu are you running.
 

·
Registered
Joined
·
934 Posts
also consider retarding the crap out of the cam since its not a y8 camshaft. Get a Y8 FPR and Y8 Cam and gear! here come the headaches!
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #6
How in the world? I thought z and y cams were not compatible? :\ Thats not a mini-me, its a frankenstein!
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #7
i fixed the problem...i tapped the broken screw out of the y8 camshaft and used it and the y8 gear...it works good now. but im still using the z6 fpr and it works perfectly with no leaks...im having vtec issues now...do i have to have the green oil pressure sensor plugged in?.. im using the msd rpm switch with a 30 amp relay...the white wire is supposed to connect to the blue dizzy wire but when i connect it the rpm tach doesnt work anymore...is there another place i can connect the white wire on the msd switch?
 
1 - 7 of 7 Posts
Top