Honda D Series Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
ok here we go i just did a MPFI swap on my 89 civic. i did the swap just as the directions call for. hell, there were two different ways and i did them both, but the crap still wont start. i am using a PG7 ecu and my ecu is throwing a code 9 which is the CPS sensor. can sum1 help me please??
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #3 · (Edited)
yeah the swap is complete as a matter of fact i checked, double checked and triple checked the wiring over and over again. all my wiring is correct according to the instructions. and then i took th pg7 out and used a pm8 and then i get a code 16 (fuel injectors), but here's the thing. i read sumwhere that you cant run odo-1 injectors with a odo-0 setup. is this true????? because i got the injectors out of a 95 civic odo-1.
 

·
Registered
1995 Civic EX Coupe
Joined
·
579 Posts
yea you need to run OBD0 injectors if you are running a OBD0 ecu. switch those out first, then make sure all the wiring is correct.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #6 · (Edited)
i ordered the injectors on eBay but i want to kno if i can use the odo-1 clip/connectors on the odo-0 injectors do they fit? and another thing is i just came from d-series.org and sum1 ova there told me that i could use the odo-1 injectors, just dont wire in the resistor box is this possible? if it is can sum1 show me how
 

·
Registered
Joined
·
248 Posts
u dont need OBD-0 injectors on a OBD-0 car, mine uses obd-2 injectors.. all the injectors matter is if u need a resistor box or not... and as for your CRANK POSITION PROBLEM "CPS" try another dizzy i got 3 bad dizzy`s in a row... just try a new one and try a PM6 ecu, thats the right one anyways might aswell try one...
 

·
Random Hero
Range Rover
Joined
·
2,624 Posts
you need to supply power to all the injectors, you can use the power (positive/+12v) wires from your two original injectors and branch those two to all 4 of your new injectors. and then just wire up the negative side of the injector to your ecu directly, or figure out the harness.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #10 ·
you need to supply power to all the injectors, you can use the power (positive/+12v) wires from your two original injectors and branch those two to all 4 of your new injectors. and then just wire up the negative side of the injector to your ecu directly, or figure out the harness.
what do you mean to the ecu directly? directly to what on the ecu?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #11 ·
so i tried not wiring the resistor box over the weekend by connecting all the yellow/blk wires together and then connecting that to the yellow/blk wires to the original yellow/blk wires from the dpfi. (tell me if i had it wrong) with this done, i tried to start and the ECU throws the same code 16. So is this Saying that i need ODO-0 injectors?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #12 ·
ok guys i did want you suggested and guess what??? it worked but there is still a problem. the car starts but it is only runnin on two cylinders (#'s 1 & 2). i think need a intake manifold gasket. it leaks water on the side of 3 and 4. i kno it runs on 2 cylinders cus on my headers 3 and 4 never get hot but it starts everytime. now what do i do????
 
1 - 13 of 13 Posts
Top