Honda D Series Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
Sometimes my car wont start and I cant hear the relay clicking when I turn the key, then a few tries later it clicks and the car starts fine..Im getting fuel but no spark and have replaced almost everything in the ignition, it just do it sometimes and sometimes it starts and revs keep going down until the engine dies. Im thinking about main realy but also im thinking about just buying a whole new ignition. Besides that the car runs fine minus some little bogging at 2,000-3,000 revs. Could all be related? BTW its a 91 Si.
 

·
The Master Fabricator
Joined
·
2,038 Posts
Check your grounds.
Rexinre had the main relay clicking and it turned out to be the ground. (ECU was not grounded)
It seems to be a pretty common issue with civics...
 

·
Registered
Joined
·
956 Posts
same with mine. After I did a auto to manual conversion, I couldnt get it to started. Somehow, the relay won't ground itself so I just cut the wires and ground it and it work. I was desperate at that tiem so I just did whatever I can to get the car running.
 

·
Registered
91 CRX Si
Joined
·
4,454 Posts
I had to replace the main relay in my 93 integra when I first bought it. It's really easy. It's located under your drivers side dash.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #5 · (Edited)
is it suppoused to click or not? when i turn the key before starting the car (moving it two times, ~three being cranking the car~) it clicks, then the check engine light turns off and then i crank the car and it turns on fine. when I doesnt hear the click its when the car doesnt start, i just keep trying until I hear a click...oir maybe im confused about the "clicking" noise.

Anyway ill take it one step at a time...ill check the relay first. What should i look for to know if it has to be replaced or a quick fix like a ground could be done?
 

·
D-series Champ
Joined
·
1,338 Posts
check your code. if you're getting fuel then it's prolly not your relay.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #7 ·
im not getting any codes...before starting the car a bunch of lights turn on (oil,battery etc..) then some lights turn off then i hear the click at the same time the check engine light turns off. Is the main relay only has to do with fuel..because if it is, i dont think thats my problem., but anyhow ill check it.

havent had time to do anything to the car, im at work, ill check it tomorrow.
 

·
Registered
Joined
·
23 Posts
well hello i did the swap dpfi to mpfi the car started and run well i tested at 7000 and the car stop running since then the car dont start i dont have spark either fuel and i dont hear the main relay thanks if anyone can help or say something
 
1 - 8 of 8 Posts
Top