Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
see above
Joined
·
4,258 Posts
Discussion Starter #1 (Edited)
now i've got this car in the garage, 96+b18b1 bottom end. obd-0 b16 head. obd-1 chassis.

for the life of me, i can not shake this solenoid code..
.. its the only code that is being thrown and it only throws it at 7k rpm.
if you unplug the solenoid it throws a code immediately .. solenoid jumped to power.. it clicks just fine and spool valve tests within spec for ohms.
a4 d6 are wired directly to the ecu and the corresponding plugs..

oil level is full.

ecu is a p72/p61, *throws same code on either ecu
i have changed pressure switches and solenoids.

they arent dirty either..

i am fucking stumped... i know generally we dont deal with lsvtec set ups or dohc b series motors.. but any help would greatly be appreciated.. im all out of ideas. and i hayt it.

this same set up made vtec just fine with no codes in a different chassis. where should i start.. valve cover/trans to chassis/t-stat ground are all in tact. new negative battery lead . ohms for the circuit is 0.05... testing all the grounds to negative.
 

·
Registered
see above
Joined
·
4,258 Posts
Discussion Starter #2 (Edited)
also interesting tid bit, the car runs better after it throws a code 21... yes that is correct. with the cel on...... the car seems to make more power throughout the entire rev range and in any instance when putting the throttle down..

no vss codes, no ect codes, its at operating temperature, speedo and tach both work flawlessly .

is the two pin plug on the pressure switch pole specific.... is it possible to mix up a4 and d6 and have them satisfied and only throw code 21?. the car does not make vtec... interesting note.. when moving the ground from the valve cover to the solenoid body it self.. it throws the code at 5k? instead of 7k...
 

·
Registered
96 ej8
Joined
·
651 Posts
Makes more power with CEL? Don't fix it then :p or if its bothering you remove the cel light from the gauge so you have to be looking at it haha
 

·
B-series Destroyer
4g 4d civic
Joined
·
913 Posts
B16 head with gsr ecu?
Is the ecu stock or chipped?
How about oil pressure?



Sent from AutoGuide.com Free App
 

·
Registered
see above
Joined
·
4,258 Posts
Discussion Starter #5
Car still does not make vtec. And it doesn't matter what ecu its on. The p72 should run it just the same. The second gen gsr which is the p61 is what I'm using.. oil pressure should be sufficient. It was a motor swap. Not a rebuild.
 

·
Registered
see above
Joined
·
4,258 Posts
Discussion Starter #6
aright.. well working 60 + hour weeks these past 3 weeks have taken a toll on my brain.. my stubborness to fight sleep hasnt helped anything...

i fixed it.....

apparently if you mix up the a4 and the d6 pins wires while running them through the firewall.... you make no vtakkkk =P..

all is well car is beast =)...

thanks fellas
 

·
B-series Destroyer
4g 4d civic
Joined
·
913 Posts
1 - 9 of 9 Posts
Top