Honda D Series Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
So I installed my SC back in March along with the crank pulley that is supplied with the kit. Ever since, the belt keeps jumping 1 groove on the charger pulley. Have any of you with the JRSC had this problem? I keep re-tensioning the belt even more everytime the belt jumps but I'm afraid that I'll over do it and it will just snap and leave me stranded.
 

·
Registered
Joined
·
1,048 Posts
you can shi, the idler pulley's are whatever is making it unbalanced and then it should stop, i had the same problem, i had to put a washer behind on of the pulley's. you can at least try it, its only worth 30 min worth of time and a 10 cent washer. yeah dont over tension the belt, i had it pop off on me once b/c i over tightened it b/c of that problem
 

·
Premium Member
Joined
·
5,910 Posts
I had to shim mine as well. I also replaced the idler pulley as it had a groove worn into it making the belt pull to the side a bit. The bracket may be tweaked a tad also check that.
 

·
Registered
Joined
·
124 Posts
I just installed my 2 weeks ago and after a week driving it kept jumping groves. But after tightening it each time just a little bit more it finaly doesnt do it any more. It hasnt just off for a week now even with driving it pretty hard.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #9
could be, has it always done this
Yeah, after the first few days of driving it happened. It does it at least once or twice a week depending on how much I drive my car.

Im going to go with your belt is stretched.
The belt is pretty tight. The first time it happened I just took it as normal stretching of the belt from the heat generated by the engine. So I thought nothing of it at first. But it just keeps jumping now and it's getting annoying.

I had to shim mine as well. I also replaced the idler pulley as it had a groove worn into it making the belt pull to the side a bit. The bracket may be tweaked a tad also check that.
Did you do that to the blower pulley? I'm considering doing that but space looks tight to get that pulley out. Not to mention that it will be pushed out closer towards the fender side once it's shimmed.
 

·
Registered
Joined
·
301 Posts
Did you use a modified alternator bracket also? The y7/y8 kits use an alternator bracket that has been milled down to move the alt. in to match the supplied crank and charger pullies. That was what caused most of the belt jumps on mine.
 

·
R2.....Zap Balls
Joined
·
5,186 Posts
Mine jumped no matter what I did. Changed the belt, tensioners, tried washers and adjusted and re adjusted everything. It still jumped. I finally said fuck it and put on a turbo after having to fix it multiple times in the rain, snow, heat, etc.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #13
I have never had this problem............ What engine do you have and what kit do you have???
I have the D16Y7 and the part number for the supercharger is 989-210

Did you use a modified alternator bracket also? The y7/y8 kits use an alternator bracket that has been milled down to move the alt. in to match the supplied crank and charger pullies. That was what caused most of the belt jumps on mine.
Yes, I'm using the bracket that was supplied with the kit.

Mine jumped no matter what I did. Changed the belt, tensioners, tried washers and adjusted and re adjusted everything. It still jumped. I finally said fuck it and put on a turbo after having to fix it multiple times in the rain, snow, heat, etc.
haha.. since it has been quite a hassle adjusting the belt I have actually been considering going turbo. Don't get me wrong, I love the SC, but for being a DD I hate having to check under the hood everytime I get to work or when I get home. :cussing:
 

·
R2.....Zap Balls
Joined
·
5,186 Posts
I have never had this problem............ What engine do you have and what kit do you have???
I have a z6 and had the charger for the same motor on mine. Don't get me wrong, I liked it for the instant power and the whine it made while boosting, but it was getting stupid having to constantly check the belt and put it back on all the time. Plus I would have never gotten to 300+ whp with the JRSC like I did with my turbo :D.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #16
Well that is the Y7 kit so it should have came with a offset crank pulley and you say you have that I do believe also that kit comes with a crappy 3 rib blower pulley that doesnt have much of a side ridge to it easily causing jumping. You might have to do very little shimming it sounds like.
hahaha yeah, I did notice that blower pulley and was like WTF! I think the temporary fix for right now just might be shimming it. The long term fix when I decide to increase the boost will have to be machining a smaller pulley with a tall side ridge to it on both ends.
 

·
Registered
Joined
·
4 Posts
I have a 98 EX with kit 989-200. My belt likes to jump a groove too. I just orderded a new pulley for it bc it looks like my pulley was rubbing the inside of the strut tower.. hence the 3 rib pulleys. i was thinking of pounding that in and changing over to a 4 rib kit. I noticed that blowe rpulley doesnt have a outer lip.. im not too big of a fan of that
 
1 - 20 of 20 Posts
Top