Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a del sol with a d16z6 that loses power when you go to pull out almost like I'm trying to pull out in 3rd or 4th. I'm completely stumped with it. Have replaced fuel pump, filter, injectors, fuel rail, map sensor, tps, distributor, cap, rotor, wires and plugs, ecu, timing belt, done compression tests (good compression) clutch, pressure plate, transmission. I'm sure I'm forgetting something I replaced but I need help what else can cause this crap. I need my del Sol. Please help.
 

·
Premium Member
Joined
·
1,952 Posts
I have a del sol with a d16z6 that loses power when you go to pull out almost like I'm trying to pull out in 3rd or 4th. I'm completely stumped with it. Have replaced fuel pump, filter, injectors, fuel rail, map sensor, tps, distributor, cap, rotor, wires and plugs, ecu, timing belt, done compression tests (good compression) clutch, pressure plate, transmission. I'm sure I'm forgetting something I replaced but I need help what else can cause this crap. I need my del Sol. Please help.
Is it just down on power? or is it breaking up? Are you sure your timing is on?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,045 Posts
check timing again
 

·
Registered
Joined
·
5,879 Posts
like above, check timing.


quit throwing parts at it. that is a dumb waste of money. PROPERLY DIAGNOSE THE FUCKING THING.

d16z6, so its obd1. is the check engine light on? does the motor rattle at all? does the car idle perfect or does it idle rough?


I would unplug MAP sensor and TPS sensor and O2 sensor. turn car on, and attempt to accelerate. this will be very bumpy and annoying, but if it pulls harder, one of those three is bad.

a shitty coolant temp sensor will cause a ton of issues.

a bad O2 will expose poor ignition and fuel performance quite easily
 

·
Brokedick Millionaire
Joined
·
40,267 Posts
What timing marks did you use when replacing the timing belt?

1 tooth retard and any D is a slug until 3000 rpms.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
I used the knick in the crank gear to the arrow on the oil pump and the can gears opposing marks lining up with the top of the head.
As far as the sensors I don't have an o2 sensor at all. I've had them out for quite some time
 

·
Registered
See above...
Joined
·
13,322 Posts
As far as the sensors I don't have an o2 sensor at all. I've had them out for quite some time
So are you tuned with that ecu then? I believe it is called "closed loop". If you have no O2 sensor, how does the motor know how to react with no readings in the exhaust pipe?
 
1 - 9 of 9 Posts
Top