Honda D Series Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #1 ·
My 89 CRX Hf has an odd issue, about half the time I start my car the intermittent setting on the wipers doesnt work. When it does work, it keeps working until I shut the car off. When they are not working I turn the key off and on and they have about a 50% chance of working.

I assume this is some relay or something on the fritz, but any thoughts or guidance would be greatly appreciated.
 

·
Registered
Integra DB9
Joined
·
445 Posts
I have a possibly related problem in the Integra. Half the time, the intermittent is what it's supposed to be. The other half, the wipers are on constant.
 

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #3 ·
Mine goes the other way, they are either working correctly on intermittent or completely off.
 

·
Asshole
Joined
·
4,112 Posts
Maybe the switch. I have to replace the switch on my infiniti because the intermittent setting doesn't work.
 

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #5 ·
I thought that at first but the switch works 100% of the time if it is working.

IE: I start the car and the intermittent setting isnt working, it doesnt matter how many times I turn on or off the switch, they wont EVER start working, until I turn the key off and back on. Then if they start working I can turn them on or off or crank up the speed or whatever and they work 100% as they are supposed to, until I turn the key off again.
 

·
Premium Member
Joined
·
1,033 Posts
Common on 92-95 civics. The fix most times is to replace the actual stalk, arm, switch. What ever you wanna call it.
 

·
Brokedick Millionaire
Joined
·
40,748 Posts
clean the contacts....just like the ignition switch....or just replace.
 

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #8 · (Edited)
You guys did read the part where the switch itself works 100% normally when it is working, and stays that way until I shut off the ignition right?

I am not talking about a brief period of time, my daily commute is almost 2 hours each way. If I start the car and the intermittent setting works, it keeps working the whole 2 hour trip 100% correctly, even if I turn the wipers off or on high or whatever, when I switch back to intermittent they work correctly every time.

The opposite is not quite true, if I start the car and the intermittent setting isnt working, I can turn it on and off as many times as I like and it still wont work, however, sometimes if I leave the intermittent setting on while driving it will suddent start working, then it will keep working 100% normally until I shut the key off.

I have a REALLY hard time believing the switch itself is bad. I assume this is a case of a relay somewhere that is going bad and sometimes gets jammed and remains open when power is supplied, or something along those lines.
 
  • Like
Reactions: hotrodj

·
Premium Member
Joined
·
1,033 Posts
I did read it. My 92 civic was having similar issues, it was the switch.
 
  • Like
Reactions: hotrodj

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #10 ·
I did read it. My 92 civic was having similar issues, it was the switch.
So your civic windshield wiper intermittent setting would start working immediately after turning the ignition key on and off, and switching the wiper switch fixed that?
 

·
Asshole
Joined
·
4,112 Posts
Dude use a multimeter or just replace the damn switch. Stop trying to argue with everyone.
 

·
Registered
Joined
·
99 Posts
Everyone here is making valid points however, the relay could be at fault. If you've ever had a motorcycle that had a wonky blinker relay then I think you would make that connection pretty quickly.
 
  • Like
Reactions: all_rice

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #13 ·
Everyone here is making valid points however, the relay could be at fault. If you've ever had a motorcycle that had a wonky blinker relay then I think you would make that connection pretty quickly.
This. I have had wonky relays that act exactly like this. Whatever is messing up is only trying to activate when the key turns on.

If it was something that tried to activate each time I flipped the switch, it would have a chance of coming on every time I hit the switch, but that isnt the case.

Also tapping or moving the switch body makes absoutely no difference.
 

·
Premium Member
Joined
·
1,033 Posts
So your civic windshield wiper intermittent setting would start working immediately after turning the ignition key on and off, and switching the wiper switch fixed that?
Seems you didn't read my reply??
"having similar issues"

If you're so sure it's the relay, than why don't you stop posting and fucking and fix it??
Dude use a multimeter or just replace the damn switch. Stop trying to argue with everyone.
Arguing with everyone seems to be his MO!!
 
  • Like
Reactions: slo_eg8

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #15 · (Edited)
Seems you didn't read my reply??
"having similar issues"
I was double checking that you were talking about the same symptoms, at best most people skim forum posts before responding, and lots only read the title, because of this I do not assume people know what I said unless they say it back in their own words.

If you're so sure it's the relay, than why don't you stop posting and fucking and fix it??
I said it acts like a relay, that doesnt mean I know which one or where it is at. Thus the point of this thread. TAAA DAAAA!

Arguing with everyone seems to be his MO!!
This is a discussion forum, dissenting opinions are part of normal, productive discussion. If we all thought exactly alike and agreed with everything everyone here said, nothing new would ever happen.
 

·
Registered
Joined
·
20 Posts
There is an Intermittent Wiper Relay in the ICU, but I could not tell you if relay itself was replaceable though.


Here's a shot of the wiper switch wiring diagram as well, if needed.


I only found this as I'm trying to trace my own electrical gremlins.
 

·
Registered
Joined
·
2,003 Posts
Discussion Starter · #17 ·
Thanks
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,296 Posts
why does we have 2 of the same threads, with the damn near same titles?
 
  • Like
Reactions: hotrodj

·
B-series Destroyer
4g 4d civic
Joined
·
913 Posts
I had the same issue. Some times it would work. Sometimes it wouldn't. Never looked into it.

However, I snapped my wiper stalk off on accident and had to replace it. Never had the problem again.
 
1 - 20 of 21 Posts
Top