Honda D Series Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
D16Y8-No Power To Injectors

I was replacing my injectors for a bigger size (450cc) aftermarket, they where suppose to be direct fit but you know ebay stuff, any way after fitting and wiring I got it to start and run , BUT i left the wires expose and when I try to move them out of the way (the car was running ) by accident the wires touch the fuel rail and sparks fly everywhere and the car shut down ,now I can not get the car to run . do they have a fuse? a relay ? or what do I need to check?
thanks for reading and helping.
2000 civic ex -D16Y8
 

·
Certified O.G.
A Shitbox
Joined
·
5,605 Posts
:buttsex:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I was replacing my injectors for a bigger size (450cc) aftermarket, they where suppose to be direct fit but you know ebay stuff, any way after fitting and wiring I got it to start and run , BUT i left the wires expose and when I try to move them out of the way (the car was running ) by accident the wires touch the fuel rail and sparks fly everywhere and the car shut down ,now I can not get the car to run . do they have a fuse? a relay ? or what do I need to check?
thanks for reading and helping.
2000 civic ex -D16Y8
 

Attachments

·
\/Your Mom Was Here\/
Vibe GT
Joined
·
4,833 Posts
2 things:

No need for 2 threads of the same subject...

Also why are you trying to start the car in that condition??? You haven't finished your build yet.


---------------------------------------------------------------------
Also, how did you wire these in, twist wires together and tape???
 

·
Tape-R taper/driver
EC3, ED8, ED9, EE5
Joined
·
574 Posts
Couple things I would check:

Check to see that the main fuse and any ECU related are intact.

I would source a known good ECU and installed it (after you clean up your mess) and see if that works. There is a good chance you fried the injectors drivers, which are on the ECU motherboard.
 

·
Tape-R taper/driver
EC3, ED8, ED9, EE5
Joined
·
574 Posts
sparks plus fuel = good!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
yea sorry for the double thread BeerDrinkin , im just looking for an answer , i was just trying to check if wire the injectors in the right position wich i did, and got the car to run but i did not tape or cover the expose wires and well you know the rest , im in the middle of my build .
and thanks LowFlyin' i will check all does thinks ,im not to worried about my ECU because i already have an other with the hondata s300 i just hope its not my injectors or wires
 

·
Registered
ej8
Joined
·
6,367 Posts
injectors are powered by the main rely and ecu ignition power.
SO trace out those wires and see if they are burn out.

They are controlled by ground from the 4 injector wires. They would also be burn out if the power wire touch them.

So get a voltmeter and start tracking down wires.

Next time be smart and not do something like that.
Also if you started the car with the turbo mount. You probably messed it up.
The turbo should have oil going to it at all times while its spining
 

·
Registered
1992 Civic DX Hatch
Joined
·
586 Posts
more than likely the 5 amp fuse for the ECU under the hood.
 
1 - 10 of 10 Posts
Top