Honda D Series Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,579 Posts
Discussion Starter #1
Hey guys im in the process of getting my h22 more reliable and lately its been acting up. When its cold outside and im driving the car will kind of lag between 2-3500 rpm. I've noticed that also when i put the car in neutral to come to a stop the idle will drop down below 500rpm and slowly come back up. I've replaced the butterfly valve gasket and the throttle body gasket so far. What could cause this. Sometimes the car would even stall out also.
 

·
Registered
Joined
·
1,579 Posts
Discussion Starter #4
it might be a vacuum leak but why would the car drop low sometimes and others run good. also that lag between 2-3k rpm would that be a vacuum leak issue?
 

·
Registered
Joined
·
106 Posts
you have to adjust the idle control on the tb, my h22 did the same thing then I adjusted it and it was all good
 

·
Boost Gets You Laid
Joined
·
4,402 Posts
Adjust idle and also what EM you using? If you're using a chipped p28/similar you might have to go back and edit your map for idle stuff too. I went through this with my turbo sol
 

·
Registered
Joined
·
1,579 Posts
Discussion Starter #7
opps i forgot to add that. yea im running a p28 chipped. how would i edit my idle? one of my friends has the stuff to tune my car so it would be helpful. also its chipped with Crome if that matters.

Thanks!
 

·
Registered
Joined
·
1,579 Posts
Discussion Starter #10
alright ill have to talk with the guy about it cause the damn car just did it again tonight. i notice it'll only do it right after being warmed up. does anyone have some suggestions for the lag in between 2-4k rpm. it only happens when im at partial throttle but once i open it up the car is just fine.
 

·
i save your ass when you wreck
Joined
·
6,693 Posts
i had this problem. i messed with my tps sensor and the idle thing under the tb and it cleared that problem up for me
 

·
i save your ass when you wreck
Joined
·
6,693 Posts
i just adjusted it
 

·
Registered
Joined
·
1,579 Posts
Discussion Starter #15
is has to deal with repair because its causing it too lag and im trying to get some ideas on what to fix
 

·
Registered
Joined
·
2,927 Posts

·
Registered
Joined
·
180 Posts
its a h22 no problem with it...i see so many h22's blow smoke...jk..but it might be a bad ecu tune...what chip? who tuned it? get the tuned checked out 1st :TU:
 
1 - 19 of 19 Posts
Top