Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
I have a 98 dx. Got a p0505 code thinking it was the iacv so i replaced it... TWICE and now the code is still there. So i used a meter and realized that i have power in the middle wire (like im supposed to) and constant ground on both sides causing the valve to fight back and forth and the idle to stay raised. Anyone have a clue what i can do to remedy this?
 

·
Registered
Joined
·
5,880 Posts
The TSB for the wiring consists of the symptoms of regularly or even constantly blowing the #15 or #16 fuse (15 or 20 amp) fuse under the dashboard.


The wiring is mostly for the d16y8 with the intake manifold bracket rubbing the wiring raw.

While not as popular of an issue on the d16y7, still, like Bone said above, check it out.

The fuse blowing regularly is the most common symptom.


If all fuses are instact and fine, I suggest following the IACV wiring to the ecu and see if there are any breaks, cuts, or other damage. Very possible a wire is smashed into the chassis by something.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #4
well i looked at the entire wiring loom and its still completely in tact from the sensor to the ecu. is it possible my ecu is bad and thats why its sending a constant ground instead of switching it on and off?
 

·
Registered
Joined
·
5,880 Posts
did you measure each of the wires to there end points? I think the IACV ground is within the harness, but power and signal go all the way to the ecu.

Lets sasy the harness is in perfect condition. at that point, I would suspect the ecu.

Where are you located? I believe I have a spare ecu from a 96 or a 97 dx automatic. Might be able to rule out an ecu problem if you are located in nearby states. Would have to wait til sunday or monday before I can go looking for it though, busy
 
1 - 5 of 5 Posts
Top