Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
Honda Del Sol ESI
Joined
·
25 Posts
Discussion Starter #1
Hello everyone,

i installed some led's in my dashboard ( cluster gauge's)

And i burned the (Google translated) "PCB" so there is no power going to the lights anymore, So i never know how fast i'm going at night Great! ^^

I dont really care that much, that it happend.

But would like to know HOW this happend,

it where just T5 fittings and i putted T5 leds in.

i can imagine that the overflow of Volts lead it to it's death, but other people do this aswell so, Here comes the real question!



"how to proper install led lights in youre cluster gauge's?"



I Don't want to make it a big mess now over here but i also have 1 other electronic problems

1. The light in my mid console don't work(Honda del sol 1996) I remember that 1 worked out of the 3 but after changing the airflow direction let's say from windshield to feets it would turn off instant(the light) any suggestions ?


U can imagine it's Pitch black in my car at night, and would like to get the feeling that i'm driving a good old Honda instead of a black box ^^


thanks already!
 

·
Registered
1987 CRXSi
Joined
·
416 Posts
if you just replaced an incandescent bulb with an LED, then you have no current limit to the LED, hence burning up the traces. An incandescent bulb has an internal resistance, as long as the proper voltage is applied to it, it will function normally. An LED has no internal limiting resistance (unless the manufacture tells you they have built it in) and you need to calculate what value is needed.

Do you have a link to the LED you used?
 

·
Registered
Honda Del Sol ESI
Joined
·
25 Posts
Discussion Starter #3
I have no link i brought them from geek/wish and i'm 100% sure they don't have that haha, anyways i will keep an eye out about the resistance stuff :) thanks
 

·
Registered
Joined
·
5,880 Posts
LED.

Light
Emitting
Diode

They only work one direction/polarity, unlike a halogen/incandescent bulb that only cares about power and ground, regardless of direction.


Do you have them installed correctly? If no worky worky, flip and retest.


Unless the LED is trying to use over 10 watts, VERY unlikely you did any damage.
 

·
\/Your Mom Was Here\/
Vibe GT
Joined
·
4,833 Posts
I'm with Matt on this, I bought some from SuperBrightLEDS.com and they worked, but if you installed it wrong it wouldn't work and then the bulbs after it wouldn't either like a set of old christmas lights.

The ones I had only lasted about a year and I got tired of removing the cluster in my truck all the time for some stupid bulbs. The old incandescent bulbs lasted 25 years and I bet the new ones will too, still working 5 years later.
 

·
Registered
Honda Del Sol ESI
Joined
·
25 Posts
Discussion Starter #6
Hello guys,

sorry for the late respond.

i have installed the leds incorrect aswell as correct.

have to see if they light on and then turn them around or not, so all leds stopped working and i can clearly see my board burned 1 "buslane" is totally brown and burned.

i have brought some red led's drilled in to the fittings, hooked all leds to a single + and - wire and made them connect to my key switch so when i turn the key all the lights will go on. looks classy!

so that's how i fixed my issue :)
 
1 - 6 of 6 Posts
Top