Honda D Series Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys,

Just installed an Edelbrock intake manifold and managed to fix all the vacuum leaks however now it idles at 2k rpm when cold and drops to 1.5k rpm when warmed up. I tried adjusting the idle screw to reduce the idle but the lowest it'd go is 1k rpm and the car shakes a fair bit. Running the car untuned at the moment since I have stock ecu.
Any ideas to reduce the idle back down to close to normal?

Mods i got are I/H/E and the edelbrock IM

Thanks in advance guys,
Matt
 

·
Registered
Joined
·
3,314 Posts
Remove the throttle cable and see if it drops, if so then you have the cable too tight
 

·
Registered
1995 Honda Civic Ex
Joined
·
361 Posts
Did you attach the throttle cable bracket correctly? If you did, as mentioned above, you probably have a hidden vacuum leak. Spray around the intake with carb cleaner and see if the idle changes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Okay found the problem! A very small vacuum leak which I fixed! Now everything is running fine. Topped up coolant however I'm getting a CEL after reaching 30km/hr. When I restart the car it goes away again until I reach 30km/hr. I'm certain that all plugs are connected in the right position.

I would check the ecu code by shorting the scs connector but I can't find the connector. I looked under the dash and nothing.

Do you guys have any suggestions as to whats causing it to light up?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,529 Posts
google where it would be and what it looks like. google how to read the codes. report back, or google the code......
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Yeah i know how to read the code, just cant seem to find it in an ej8, i know where it is on the CRV's but yeah lol
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
AUDM civics came with no OBD Connectors im pretty sure. I'll look for the SCS Connector tomorrow again. Any chance i may have connected the plugs on the TB wrong?
 
1 - 11 of 11 Posts
Top