Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Guys my car hesitates usually in fourth gear at around 2000rpm, I mostly notice this while going downhill foot off gas, but when I apply the gas I notice it hesitates or bucks. Sometime I notice it will do it in 3rd gear also. Everything has been done to this zc dohc motor, complete tune up, new fuel filter also replaced the tps. Another problem, not sure if it's related is the car will not start in the morning normally. When I go to start it will run rough for a few seconds then even out and idle normal. I have a fuel pressure gauge hooked up and I am getting 27psi at idle with the fpr connected, I am not sure if that is normal or not. Any ideas?
 

·
Registered
1993 Honda Civic EX
Joined
·
93 Posts
Could be a lot of things, o2 sensor, fuel filter, fuel pump...


Keep it simple and swap out the o2 sensor. I had a problem similar to that after I reused an old o2 sensor when installing my exhaust.

Bought a new one and threw it in, ran fine afterwards.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
thanks DocHoliday. I was thinking that also but the O2 sensor is new , but who knows maybe it's bad. What make O2 sensor do you recommend?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
Chech your pcv as well just to make sure it's working properly.
Funny you mention that, I replaced that also with a new oem one but I noticed it makes a lot of noise until the engine warms up. The little ball seemed like it was hanging up when you would shake it.
 

·
Registered
1993 Honda Civic EX
Joined
·
93 Posts
thanks DocHoliday. I was thinking that also but the O2 sensor is new , but who knows maybe it's bad. What make O2 sensor do you recommend?
Many brands available at a local parts store or RockAuto are good o2 sensors. Stay away from the ebay ones, their often cheap but aren't made well.

If you pull out the sensor and it appears fouled, you might have a bigger issue than just a sensor. A new o2 sensor should not go bad for a long ass time.


Best of luck my friend and keep us updated
 

·
Registered
88 Civic Hatch
Joined
·
925 Posts
I had trouble with a car 'breaking up' at about 4k come to find out it was the cps in the distributor. The reluctor had worked its way into the coil pick up and caused the issue. just a bit of info I figured you would find useful.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #8
I had trouble with a car 'breaking up' at about 4k come to find out it was the cps in the distributor. The reluctor had worked its way into the coil pick up and caused the issue. just a bit of info I figured you would find useful.
Thanks I will keep that in mind. I tried my spare ecu and no change. I just ordered another O2 sensor and will let you guys know what happens. thanks and keep the suggestions coming.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #9
Could be a lot of things, o2 sensor, fuel filter, fuel pump...


Keep it simple and swap out the o2 sensor. I had a problem similar to that after I reused an old o2 sensor when installing my exhaust.

Bought a new one and threw it in, ran fine afterwards.

Thanks for the help everyone, it looks like the denso o2 sensor was the problem. I replaced it with a NTK and she is running good so far.:clap:
 
1 - 9 of 9 Posts
Top