Honda D Series Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
okay so ive come into a problem. just swapped a zc sohc vtec into my 88 crx si, did all the obd 1 wiring correctly. getting spark, too much fuel, and redlines at 4k rpms. running a p28 ecu. its currently idling at 1.5k rpms. only mods on it are a header, ngk wires, and a skunk2 cam gear. Ive tried other p28's on it to see if it were the ecu, but it seems that my ecu is the only one that will run my car. when i drive the car there seems to be reallly no power when i punch it, but redlines at 4k. any info on the matter would help. thanks
 

·
Registered
Joined
·
98 Posts
Discussion Starter #4
not throwing any codes either. checked the timing a few times already. I might throw the stock cam gear back on and see if it helps.
 

·
Registered
Joined
·
1,217 Posts
the hell is 710?

if cam timing is off quite a bit. it will cause this. if the ecu is bad it will do that as well.
 

·
"Wild Bush Appeared!"
???
Joined
·
1,898 Posts
...and upside down...you fail, lol, epic fail....

Oil wouldn't do that. You got all of your vacuum lines ran right?
The person talking about "limp" mode. The p28 will make that happen if it notices you are too low on oil. It wont' let VTEC engage on VTEC engines and it lowers the redline. Try changing the oil.
 

·
Registered
90 CRX Si
Joined
·
3,866 Posts
The person talking about "limp" mode. The p28 will make that happen if it notices you are too low on oil. It wont' let VTEC engage on VTEC engines and it lowers the redline. Try changing the oil.
Yea but it wouldn't lower it that low AFAIK.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #15
Im only hitting 4k with a bad tps so check that out man.
it has oil.. i just bought the motor from hmotorsonline so i dont think the tps is bad but i'll still check it out. its starting to piss me off already wasting all of this fuel and having no power. :(
 

·
"Wild Bush Appeared!"
???
Joined
·
1,898 Posts
it has oil.. i just bought the motor from hmotorsonline so i dont think the tps is bad but i'll still check it out. its starting to piss me off already wasting all of this fuel and having no power. :(
Looks like you should give them a call or do you think they are going to say it was your fault if somethings wrong?
 

·
Registered
88 ED6
Joined
·
5,511 Posts
Maybe wiring issue somewhere? Bad ground?

I'm guessing a defective ECU would always be in limp and give fuel and ignition accordingly, while a working ECU wouldn't even start because maybe not all parameters needed are given(like a bad distributor so no position signal).
 

·
Registered
Joined
·
17 Posts
Have you pulled the plugs out to see which cylinders smell of raw fuel? If to much raw fuel gets into the exhaust system it can damage the catalytic convertor and cause back pressure which would not allow the vehicle to go over certain rpm. i would just fall flat on its face. Also fuel in the oil thins it out so you might want to change it. i dont think ecm because you would have more than one problem.
 
1 - 20 of 25 Posts
Top