Honda D Series Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1995 Honda del sol with a turbocharged d16z6 motor that i have had as a project car for the past few years. In high school at a post secondary school i rebuilt the the entire bottom end. Bore 40 over, New pistons, Rods, just about everything for the bottom end. 3 angle valve job on the head, adjustable cam gear, over sized injectors, etc... Just finally finished the car and had it out for about a week and put about 200 miles on it. Did a oil change on it and then drove about 2 miles when i heard what i thought was a loud backfire then the engine died. now it cranks but that is it, oil light came on along with my battery light. i checked my timing belt and it is still fine but i could see that my adjustable cam gear had moved 1 notch retarded. it is not leaking anything from any where. I think it may be the piston rings but im not sure.... if anyone has any ideas on what may have happened or what im going to have to do to figure out what happened PLEASE let me know!!!!
 

·
D-series WTF?!?!
Dyno GT Racing Bike
Joined
·
3,674 Posts
Start with the dizzy u seem to mention every motor part but have u open the dizzy cap inspect ur rotor, open ur valve cover check your timing belt inspect the lil shit before u take of your head
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
There is still oil i checked the distributor cap and there was a little bit of corrosion inside but nothing major still gets spark and everything. The timing belt is still tight and lined up correct(i moved the adj cam gear back to 0 after i noticed that it moved)
 
1 - 4 of 4 Posts
Top