Honda D Series Forum banner
1 - 20 of 31 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hey guys!
This is my first ever post on this forum. So first of all, hello to you all! And thank you for all the good threads!

I just swappe this d16z6 into my ej9/ek 1.4iS european version. And it had this weird distributor on it.

136493


It looks like a regular obd1 dizzy. But it only has 7 wires coming out of it? My guess is the previous owner cut the plug of it, and converted it somehow? But my issue is, the wire colors don’t really match any other dizzy/wiring harness diagram I can find online?
I’m running a obd2a harness with this plug onbut it needs 9 wires? I can find a diagram of the harness. But none what so ever of this specific dizzy??

136494


So if you know something, PLEASE help! I’m really stranded here ☹

Best regards Silas.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
are you sure its not a stock z6 distributor? or d15b7?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
you should open it up it probably has a missing wire borrowed/broken off inside.

what are the colors can't see the stripes ..
I have now taken the dizzy apart. It doesn’t look like it’s been tampered with. Not what I can tell at least. But then again, I’m not much of a Honda mechanic 😅
But it’s clear that it’s been opened.
Here’s some pictures. It looks like the wire colors are a bit faded??
136504
136502

Auto part Technology Vehicle Automotive engine part Car


Hope this pictures helps a bit.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
are you sure its not a stock z6 distributor? or d15b7?
I’m not really sure of anything.. Honestly I’m not much of a Honda guy. This is my first 🙂
But I can’t really match the wire colors to any diagram I can find online??
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
any markings on the dist?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
a google search of those numbers say its a d16z6/z1 dist
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
a google search of those numbers say its a d16z6/z1 dist
Yes. But the colors mine have, is not the same as the factory dist...
Also, the factory one have 9 wires. Mine only has 7. Is it because different stuff needs the same signal/wire?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
the obd1 also has 2 plugs. (1) 7 wire and (1) 2 wire.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
5,289 Posts
its to show you they came with 2 plugs in obd1.
 
  • Like
Reactions: Silas

·
Registered
Joined
·
22 Posts
Discussion Starter · #20 ·
was there 3 sensors inside ?not

so this can;t be used ?
external crank sensor/?
There were only two sensors.. can I wire the sensor from the transmission to the distributorplug??
It’s the CYL sensor I’m missing.
 
1 - 20 of 31 Posts
Top