Honda D Series Forum banner
1 - 16 of 16 Posts

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #1 ·
Alright so here's the deal. I just got my buddy to weld my new radiator support on. On the way out there I had working lights. After we got the new support welded on we hooked the headlights up. The drivers side was fine, the passenger side has high beam but no low beam. Then as I was leaving I kept getting the door/seatbelt light. After a few seconds I figured out the seatbelt light comes on when I hit the brakes. Then I noticed the brake lights do NOT come on when I hit the brakes. Not sure if I have taillights or not. Signals are working fine, no fast flash or anything. I checked all the wires and I can't find anything that may have shorted or hit a ground. Any suggestions are appreciated. If you have a question that may help my diagnosis toss it out there. Stock bulbs in headlights and tail lights and I checked the passenger lowbeam and the bulb is fine.
 

·
Worst Mechanic Ever!
EG
Joined
·
2,915 Posts

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #5 ·
This is gonna sound dumb, but... there's a lot of grounds. Which one are you guys suggesting I check? Also if it matters I don't have bulbs in one of my corner lights. BTW rep for all who have decent suggestions.
 

·
Worst Mechanic Ever!
EG
Joined
·
2,915 Posts
This might sound dumb, but all of em. Grab a manual, see where the grounds are (I don't know off the top of my head) and check em. Wish I could be more help but I don't have much experience in this matter, only second hand knowledge.
 

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #7 ·
Damn, it doesn't sound dumb at all, that's what I was afraid of. LOL. I was hoping to narrow it down, guess it was wishful thinking. I'll be checking grounds and fuses all night. I need a rum and coke.:hammer:
 

·
FAMILY MEMBER #316
Joined
·
2,955 Posts
maybe there is corrosion built up in the actual headlight sockets/assemblies. my driver side corner fucks up on me occasionally and that ONLY happened after i changed the bulb (ie moved light socket) over 2 years ago. i spray some contact cleaner in there and shes good to go for awhile. as far as i know there isnt a single fuse for sole brake light operation so i would check the brake switch. other than that, definetly want to check dem grounds...it could be as simple as tightening them or as crappy as loosening them, cleaning, then re-tightening.

i dont know much about welding, but dont you have to ground that thing to whatever your welding (ie the vehicles frame and home to all vehicle grounds)? maybe that ground (for the welding) wasnt so great and it couldve damaged some electronics in the car?
 
  • Like
Reactions: 16333

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #9 ·
maybe that ground (for the welding) wasnt so great and it couldve damaged some electronics in the car?
Oh holy batshit, I don't even wanna think about that one as a possibility.
 

·
Registered
93 celica
Joined
·
323 Posts
i dont know much about welding, but dont you have to ground that thing to whatever your welding (ie the vehicles frame and home to all vehicle grounds)? maybe that ground (for the welding) wasnt so great and it couldve damaged some electronics in the car?
that would suck monkey balls.... hopefully its just the switch i had a similar problem with my headlights recently.. it's the switch in my case....
 

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #12 ·
Do you guys think the headlight and tail light issues are related? I'm thinking yes, but not really sure.
 

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #13 ·
no other ideas huh? cmon guys THINK!!
 

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #14 ·
Alright so the headlight was just the left low beam fuse. i didn't know they actually had a fuse for each bulb! Brake lights are still a no go. My manual is useless.
 

·
Registered
97 GSX-R 750
Joined
·
1,548 Posts
Discussion Starter · #15 ·
Got it bitches!! 0wn3d by a blown under hood fuse. I'm back on the road, not satisfied by far, but back on the road!!
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top