Honda D Series Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Have a 94 civic with a mini me swap. Has the d15b2 block and del so head vtec. Am at loss. New fuel pump, new relay, new fuel pump, new dizzy. I have a spark. Took spark plug out has fuel on it. Sprayed starter fluid in intake and won't start. When I try to start battery light is in on CEL is on I can hear the pump. However the tach doesn't move at all. Please help me I need to get running so I can take my ass to work. Thank you in advance.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,110 Posts
check your fuses and timing as well as all the grounds.
 

·
Registered
Joined
·
5,880 Posts
download a civic tech manual and test the ignition module and coil if its one of those garbage ebay dizzies
 

·
Registered
Joined
·
5,880 Posts
autozone distributors are nearly identical to the ebay ones. cheap stuff that randomly fails.

you sprayed starter fluid and it didnt fire. its the ignition. EDIT assuming compression is fine, headgasket sealed properly, and your mechanical timing is correct, aka, camgear lined up, crankpulley lined up at TDC to be checked /EDIT

Distributor position looks fine.

Did you download a manual and tes tthe ignition coil?

No one here can tell you an answer directly without some form of diagnostic data.

Throwing parts at it is foolish if you cannot verify the parts are even making a difference.

Find a few hours of time if you can, and plow through a manual.

Pull out a multimeter, and verify you are even getting voltage where it needs to be present.

Part of being a DIY mech or self-service, is to be resourceful. Its an awesome skill.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
autozone distributors are nearly identical to the ebay ones. cheap stuff that randomly fails.

you sprayed starter fluid and it didnt fire. its the ignition. EDIT assuming compression is fine, headgasket sealed properly, and your mechanical timing is correct, aka, camgear lined up, crankpulley lined up at TDC to be checked /EDIT

Distributor position looks fine.

Did you download a manual and tes tthe ignition coil?

No one here can tell you an answer directly without some form of diagnostic data.

Throwing parts at it is foolish if you cannot verify the parts are even making a difference.

Find a few hours of time if you can, and plow through a manual.

Pull out a multimeter, and verify you are even getting voltage where it needs to be present.

Part of being a DIY mech or self-service, is to be resourceful. Its an awesome skill.
Thank you bro... Thing is I don't know what to text I thought I'd I got spark then things are working.

I'm find the Manuel and go over it. Thing is I leave house at 315 am and get back at like 7 pm... Have to spend some time with my princess but tomorrow I have off so I'll do some reading and testing.

I know it's foolish but have no help and no idea what to do.... So that's a problem lol.

Please bear with me. I'm smart and a quick learner. I won't always be this guy lol.. Thanks again
 

·
Brokedick Millionaire
Joined
·
40,313 Posts
Do a compression test, esp. after is has been sitting.

Also, you don't happen to use Speedway/Super America gasoline do you?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
Do a compression test, esp. after is has been sitting.

Also, you don't happen to use Speedway/Super America gasoline do you?
No I use am pm gas lol... And I'll do compression test as well as test ignitor today.
Thank you for the help..... I'm super lost lol
 
1 - 12 of 12 Posts
Top