Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
97 honda coupe
Joined
·
7,611 Posts
Discussion Starter #1 (Edited)
So i recently bought a set of hasport mounts for my crx, they were the crx d-series cable to hydro setup. First off, they didnt have it listed on the website, no big deal so i called them. Talked to one of the guys and made my order then hung up.

About a week later i havent received my package, so i send an email asking for a tracking number or atleast an update on where my package is. His reply was "I forgot to make the invoice up, ill have it shipped out today".

I was a little furious since now by the time of him sending me back the text it was already a week an a half since i had ordered them. i asked him if he could give me a hand with shipping because i wanted them on Friday so i could put them on and get my car done over the weekend. He agreed and friday afternoon i received them, Although he made a small mistake (which he rectified) i would still do business with them. since the customer service was good, and the guy was knowledgeable of the parts i needed.

Now for the actual product review. I received the drivers side mount, rear bracket and pass "plate" adapter that you use with stock mounts. The drivers side mount, worked perfectly and looks beautifull in my engine bay. The passenger mount fit up perfectly, however the bolts that came with the package were a little off. I would have either had to remove both of my studs in the transmission and run bolts in the tranny, or get new nuts to go on the studs. This was due to the fact that the adapter plate was much thicker than the stock mount, and the stock stud-nuts had a large lip on them before they got to the threads, so you would end up with about 3 or 4 threads actually grabbing with none sticking out.

No big deal since i had a few bolts laying around, then i went to put the mount on, Its possible that my frame is bent but for some reason it was really hard to get everything lined up, moreso than my standard cable mounts were. However i did get them lined up and situated, my passenger mount sits a little crooked and im not sure why, but it works and its not at a terrible angle.

Now as for the rear mount bracket. It was way off, im not sure if it was because im supposed to buy the hasport mount (that mounts on the subframe) or they sent me the wrong part, but its exactly 2 inches off from the stock mounts (that i was under the impression that it would use the stock mount only the bracket was changed). So i ended up reinforcing a hush22 mount and im using that currently.





 

·
Registered
Joined
·
1,629 Posts
I bought some used hasport mounts for $50 with bad inserts. They were the first model ones. Aluminum.
Sent them to hasport gottem back maybe a week & ahalf later. FRESH.
Painted, new inserts, nicely packaged & only $10 outta my pocket for shipping.
 

·
Brokedick Millionaire
Joined
·
40,313 Posts
HASport mounts are a PITA to get lined up. On the two B16 swaps I helped on you needed a floor jack and cherry picker to get the motor level both front to back and side to side.

I joked with BrianG. years ago stating it was as if the motor mounts were keeping the frame from spreading, no wiggle room.
 
1 - 6 of 6 Posts
Top