Honda D Series Forum banner

1 - 20 of 87 Posts

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #1 (Edited)
Ghost: Another CRX build.

bought my new toy back in april, a true 1990 CRX Si shell. Shweet!



hauled this little beast 6 hours from richmond VA.

decided to do a little work.

z6 block/crank
D16 eagle h Beams
SRP A6 pistons -2.9 dish
ARP Studs
.066 cometic head gasket. i know its pushing it.
y8 head with y7 internals
ferrea 5000 valves
SOHC ZC trans with LSD conversion (rebuilt by whoopdee doo racing)
action clutch 2Md if i remember right
custom 0bd0-1 conversion harness (by 2JZdreamin)
innovative mounts.
rebuilt starter
130 amp alternator
skunk2 intake
OBX headers
HKS exhaust
completly rebuilt shift linkage.















--------------------------------------
 

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #2




did a little bay touch up. definantly not hte best. with my skill level im just trying to prevent rust.







it was my first time wrapping a header and i dont think it came out too bad.





the sweet sweet LSD. i have always wanted one.


i ran out of time this week to finish the project, and i made a critical part error. i dont normally work on cable clutches, so i didnt order the clutch cable bracket that atthes to the transmission. pedal goes straight to the floor and stays there, but the part is on its way now!

---------------------------------------
 

·
Meat Popsicle
91 CRX Si
Joined
·
2,939 Posts
Seeing the cleanliness of the engine assembly makes my balls wet. Good job on that!

That HG in the pic doesn't look like the cometic I used, judging by the coolant holes. Who knows, maybe they stepped up their game and followed the design if the Y8 HG holes

And yeah, header wrap is a pain in the dick. You'll learn real quick to wear a mask , gloves, and a long sleeved shirt!

Hopefully this is just a toy and not a DD as that header wrap on the downpipe can easily lead to rust and corrosion if it seems any amount of water on it
 

·
Registered
Love the Civic
Joined
·
1,817 Posts
Looks super nice, good work thus far.
 
  • Like
Reactions: theft-repo-sol

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #7
Seeing the cleanliness of the engine assembly makes my balls wet. Good job on that!

That HG in the pic doesn't look like the cometic I used, judging by the coolant holes. Who knows, maybe they stepped up their game and followed the design if the Y8 HG holes

And yeah, header wrap is a pain in the dick. You'll learn real quick to wear a mask , gloves, and a long sleeved shirt!

Hopefully this is just a toy and not a DD as that header wrap on the downpipe can easily lead to rust and corrosion if it seems any amount of water on it
hey thanks man... i was really trying to build the cleanest little d-series i could. the HG is a true cometic, i didn't even notice the holes until you said something. i watched a bit of a tutorial before i did the header wrap


it really helped getting the basic concept down, but i still got ate up by the fibers on my arms. itches like a bitch! good looking out on the rust on the wrapped header i didnt know that. +

Looks clean nice find
thanks man, cant wait to start driving it

Looks super nice, good work thus far.
thanks man!

Super clean, what kind of spoiler is on it?
thanks man, i was really trying and i honestly don't know what spoiler is on the car it was attached when i got it. i have the number of the original owner so ill ask him when i text him with details about the car.

i found a couple of more pics.







i do have bad news about the build. the part i needed "stay, clutch wire" bracket is no longer available. its part number 22871-pl3-050 or 22871-pl3-030 and the two bolts that attach it to the transmission.
 

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #9

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #10
got a little bit done today.

refurbed the shift linkage and installed it.



got a new 92-95 linkage and used the u-bracket piece to refurbish the old 88-91 (discontinued) linkage.
first i grind off the big rivet (closest to the bar linkage). then drilled out the small hole to 1/2" transferred over all the good bushings etc. and finally a trip to lowes for the hardware and tadaa spiffy like new linkage.

all new rubber and plastic components from the ball to the transmission. man its so nice!



mocked up and fabricated teh positive and ground wires for the CRX.





this is one example of the dirtyness that was in the car.



and began work on the exhaust system and wide band mock-up. dont have any pics of teh wide band yet.



had to stop installing the exhaust because the intermediate pipe was about four inches too long and ill have to take it to a muffler shop for fitment. im hoping for an open down-pipe first start.
 

·
Registered
Love the Civic
Joined
·
1,817 Posts
Nice job on the linkage. Getting close.
 

·
Registered
Joined
·
333 Posts
Holy gorgeous and clean. Makes my nipple hair stand up. Giggity.
 
  • Like
Reactions: theft-repo-sol

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #13 (Edited)
CRAPPY FIRST START
As per usual with a y series head on a z6 block you get timing issues.
it fired but not for very long. ill have to tear it down and replace the pm3b gear with an adjustable. i should have done this in the first place but hind sight is twenty twenty. the motor runs best with the dizzy fully retarted (towards the fire wall).



https://www.youtube.com/watch?v=7B5wVT2cnCs&feature=youtu.be

what do you guys think?
im going to take a bit of a break from it for a few days and think about it. wooooosaaaaaaa.....
 

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #14

·
Premium Member
Joined
·
5,819 Posts
Looking good man.

It could be timing issue but could be tps not set right or the valve lash is to tight or to loose.

What throttle body are you using?
 

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #17 (Edited)
This staying na or you just using what you have to breakit in and then go boost?
im going to stay N/A until i can afford to have my JRSC eaton M45 blue printed and rebuilt. itll probably next spring, but that is a solid break in time for the motor.

Looking good man.

It could be timing issue but could be tps not set right or the valve lash is to tight or to loose.

What throttle body are you using?
im agreeing with everything you're saying. i slept on it and decided to finish the exhaust, calibrate/screw in the wide band sensor, install the adj cam gear (just in case) but keep the current pm3b settings and install Neptune in order to calibrate all the sensors. then if it is still acting up ill redo the valve lash. the throttle body is a 70 mm god speed with the correct gasket and skunk 2 intake. everything i listed could be a variable (including the TB) , so now i have to begin the long process of elimination. hell it could even be a random vacuum leak. rep to 2jz for solid suggestions thanks brother.
oh i had an issue starting the car , and had so much faith in your harness i started looking elsewhere. it turned out to be the stupid rubber stopper on the back of the clutch pedal (which took 2 hours to find). install some hardware and it cranked fine. again excellent work on the harness not a single CEL when i first turned the key.

crap must spread rep. some one rep this man for me!
 

·
Premium Member
Joined
·
5,819 Posts
Try a stock throttle body. I had the same problem using the skunk2 throttle body,ran perfect with the stock throttle body. I haven't been able to figure out if it's was the sk2 throttle body and or it needs to be tuned.
 

·
Premium Member
theft repo sol
Joined
·
357 Posts
Discussion Starter #19
finally got it running alright......
ive had some mishaps along the way.
i didnt have the ground tightened all the way down and i think i cooked my ECU, because the car will only run in limp mode. at first the ECU flashed code 15=ICM, and code 20=ELD. after rebuilding the dizzy from known good parts i got a code 4= CKP sensor and a code 20=ELD. rebuilt the dizzy with tested and known good parts and got code 4 and 20 again. psjones13 and i traced the wiring all the way back to the ECU and it all checked out. at this point of the pin out test the FSM tells you to find a known good ECU...LOLS FML!
HEY it does run.
the transmission i had rebuilt by Aquafina took a big shit. as you'll hear in the video a whinning noise. yeah it is the transmission. bummer. the trans eventually quits the whining and does a weird almost silent grinding noise. i dont know tried to get ahold of aquafina but to no avail. ill try again tomorrow. in the mean time i have to find a transmission and p06 ECU.

https://www.youtube.com/watch?v=DNiedUIAGvg&feature=youtu.be

https://www.youtube.com/watch?v=x4oORzVsIjA

when i got the clutch to engage the right wheel would not spin, but the driver side was good. thought it was a stuck caliper so i smashed it down. nope so i tried to use a breaker bar for leverage and applied light pressure to turn the axle. nope, didnt budge. i stopped at this point because i didnt want to ruin it any further.

https://www.youtube.com/watch?v=W6B4hQyDzfA

on a good note i did finish the fabrication and installation of the HKS exhaust. wideband is installed calibrated and working properly. got the adjustable cam gear dialed in and the mechanical timing on.
 

·
Premium Member
Joined
·
5,819 Posts
Man that is a clean Rex. Don't go crazy with the eld code. I never wire for it as people just disable it. The cel shouldn't be on from the eld but will show up when you code scan it. Sucks about the tranny. Can't wait to see rippers.
 
1 - 20 of 87 Posts
Top